pww

python-weka-wrapper3

Python 3 wrapper for Weka using python-javabridge.

Showing:

Readme

python-weka-wrapper3

Python wrapper for the Java machine learning workbench Weka using the python-javabridge library.

Requirements:

  • Python 3
    • python-javabridge (>= 4.0.0)
    • matplotlib (optional)
    • pygraphviz (optional)
    • PIL (optional)
  • JDK 8 or later (OpenJDK 11 recommended)

Uses:

  • Weka (3.9.5)

Installation

Detailed instructions on installing the library on various operating systems are located here:

https://fracpete.github.io/python-weka-wrapper3/install.html

Please note, that you need a build environment to compile some libraries from source.

Forum

You can post questions, patches or enhancement requests in the following Google Group:

https://groups.google.com/forum/#!forum/python-weka-wrapper

Examples

Documentation

The complete documentation for the library is available from here:

https://fracpete.github.io/python-weka-wrapper3/

Download statistics

For viewing recent download statistics, go to pypistats:

https://pypistats.org//api/packages/python-weka-wrapper3/recent