nnabla-ext-cuda110-nccl2-mpi3-1-6

A CUDA Extension of Neural Network Libraries

Showing:

11 Versions

1.23.0

release-note-bugfix

release-note-build

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.

1.22.0

release-note-break-compat

release-note-bugfix

release-note-build

release-note-core

release-note-op-layer

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.

1.21.0

release-note-break-compat

release-note-bugfix

release-note-build

release-note-doc

release-note-op-layer

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.

1.20.1

release-note-bugfix

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.

1.20.0

release-note-bugfix

release-note-build

release-note-core

release-note-doc

release-note-op-layer

release-note-utility

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.

1.19.0

release-note-bugfix

release-note-build

release-note-core

release-note-op-layer

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.

1.18.0

release-note-bugfix

release-note-core

release-note-op-layer

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.

1.17.0

release-note-bugfix

release-note-build

release-note-core

release-note-op-layer

release-note-utility

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.

1.16.0

release-note-bugfix

release-note-build

release-note-core

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.

1.15.0

release-note-bugfix

release-note-build

release-note-op-layer

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.

1.14.0

release-note-bugfix

release-note-build

release-note-core

release-note-op-layer

Install the latest nnabla by:

pip install nnabla
pip install nnabla-ext-cuda102 # For CUDA version 10.2 users

You can also install the cuda extension with specific versions from one of the following. See also FAQ

  • nnabla-ext-cuda100 (CUDA 10.0 x cuDNN 7.6)
  • nnabla-ext-cuda102 (CUDA 10.2 x cuDNN 8.0)
  • nnabla-ext-cuda110 (CUDA 11.0 x cuDNN 8.0)
pip install nnabla
pip install nnabla_ext_cuda102  # For CUDA 10.2 x cuDNN 8.0 users

For distributed training, You need to install the correct package that matches the version of MPI installed on your system.

We prepared following packages.

  • nnabla-ext-cuda100-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda100-nccl2-mpi3-1-6
  • nnabla-ext-cuda102-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda102-nccl2-mpi3-1-6
  • nnabla-ext-cuda110-nccl2-mpi2-1-1 (Ubuntu18.04 default)
  • nnabla-ext-cuda110-nccl2-mpi3-1-6

If you want to use a version of MPI not listed above, you need to build it from the source.

Additional setup may be required depending on your OS or environment. Please check Python Package Installation Guide for details.

Install Guide To use C++ inference feature, follow the demonstration on MNIST inference in C++.

Demonstration

Build Guide The "nnabla-ext-cuda" package is temporarily unavailable. Use of this package is not recommended. Please install nnabla-ext-cuda110, nnabla-ext-cuda102, nnabla-ext-cuda100 instead. The following nnabla CUDA extension packages have been deprecated and the PyPi repository has been (or going to be) closed.

  • nnabla-ubuntu16
  • nnabla-ubuntu18
  • nnabla-ext-cuda
  • nnabla-ext-cuda80
  • nnabla-ext-cuda91
  • nnabla-ext-cuda92
  • nnabla-ext-cuda101
  • nnabla-ext-cuda90-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu16
  • nnabla-ext-cuda100-nccl2-ubuntu18
  • nnabla-ext-cuda101-nccl2-ubuntu16
  • nnabla-ext-cuda101-nccl2-ubuntu18

The following "nnabla-ext-cuda" docker images have been deprecated.

  • py27-cuda92
  • py36-cuda92
  • py37-cuda92
  • py27-cuda92-v1.0.xx
  • py36-cuda92-v1.0.xx
  • py37-cuda92-v1.0.xx

We've decided to change nnabla's versioning policy to semantic versioning. This change has been applied from version 1.1.0.

Python 2 is no longer be supported from v1.5.0. CUDA8.0 is no longer be supported from v1.6.0. Python3.5 is no longer be supported from v1.14.0. CUDA9.0 is no longer be supported from v1.14.0.