google-cloud-dialogflow

Python client for Dialogflow: Design and integrate a conversational user interface into your applications and devices.

Showing:

Popularity

Downloads/wk

0

GitHub Stars

325

Maintenance

Last Commit

2d ago

Contributors

31

Package

Dependencies

3

License

Apache 2.0

Categories

Readme

Dialogflow: Python Client

|ga| |pypi| |versions|

Python idiomatic client for `Dialogflow ES`_

Dialogflow ES_ is an enterprise-grade NLU platform that makes it easy for developers to design and integrate conversational user interfaces into mobile apps, web applications, devices, and bots.

  • Dialogflow ES Python Client API Reference <https://googleapis.dev/python/dialogflow/latest/index.html>_
  • Dialogflow ES Documentation <https://cloud.google.com/dialogflow/es/docs>_

Read more about the client libraries for Cloud APIs, including the older Google APIs Client Libraries, in Client Libraries Explained <https://cloud.google.com/apis/docs/client-libraries-explained>_.

.. |ga| image:: https://img.shields.io/badge/support-ga-gold.svg :target: https://github.com/googleapis/google-cloud-python/blob/master/README.rst#ga-support .. |pypi| image:: https://img.shields.io/pypi/v/google-cloud-dialogflow.svg :target: https://pypi.org/project/google-cloud-dialogflow/ .. |versions| image:: https://img.shields.io/pypi/pyversions/google-cloud-dialogflow.svg :target: https://pypi.org/project/google-cloud-dialogflow/ .. _Dialogflow ES: https://cloud.google.com/dialogflow/docs/

Before you begin

#. Select or create a Cloud Platform project. #. Enable billing for your project. #. Enable the Google Cloud Dialogflow API. #. Set up authentication with a service account so you can access the API from your local workstation.

.. _project: https://console.cloud.google.com/project .. _Enable billing: https://support.google.com/cloud/answer/6293499#enable-billing .. _Enable the Google Cloud Dialogflow API: https://console.cloud.google.com/flows/enableapi?apiid=dialogflow.googleapis.com .. _Set up authentication: https://cloud.google.com/docs/authentication/getting-started

Installation

.. code-block:: shell

pip install google-cloud-dialogflow

.. note::

We highly recommend that you install this library in a
`virtualenv <https://virtualenv.pypa.io/en/latest/>`_.

Supported Python Versions ^^^^^^^^^^^^^^^^^^^^^^^^^ Python >= 3.6

Unsupported Python Versions ^^^^^^^^^^^^^^^^^^^^^^^^^^^ The last version of this library compatible with Python 2.7 is dialogflow==1.1.0.

Usage

View usage documentation <https://googleapis.dev/python/dialogflow/latest/index.html>_.

Versioning

This library follows Semantic Versioning <http://semver.org/>_.

This library is considered to be stable. This means and that the code surface will not change in backwards-incompatible ways unless either absolutely necessary (e.g. because of critical security issues) or with an extensive deprecation period. Issues and requests against GA libraries are addressed with the highest priority.

More Information: Google Cloud Python Library Support <https://github.com/googleapis/google-cloud-python/blob/master/README.rst#general-availability>_

Contributing

Contributions welcome! See the Contributing Guide <https://github.com/googleapis/python-dialogflow/blob/main/.github/CONTRIBUTING.md>_.

License

Apache Version 2.0

See the LICENSE file <https://github.com/googleapis/python-dialogflow/blob/main/LICENSE>_ for more information.

Rate & Review

Great Documentation0
Easy to Use0
Performant0
Highly Customizable0
Bleeding Edge0
Responsive Maintainers0
Poor Documentation0
Hard to Use0
Slow0
Buggy0
Abandoned0
Unwelcoming Community0
100