Vialer-pjsip-iOS

A Vialer specific PJSIP build distributed through cocoapods

Showing:

Popularity

Downloads/wk

0

GitHub Stars

64

Maintenance

Last Commit

2yrs ago

Contributors

6

Package

Dependencies

0

License

GNU GPLv3

Categories

Readme

Vialer-pjsip-iOS

The Vialer PJSIP pod exposes the PJSIP library as Cocoapod.

The most important part of the project is the "vialerbuild" script. It will:

  • download a specified version of PJSIP from SVN.
  • compile PJSIP for all iOS architectures.
  • Decide whether to compile OpenSSL, OpenH264 and OPUS into the PJSIP source. By default they are included for all iOS architectures.
  • build a fat static library.
  • wrap the fat library in a framework.

Status

Currently active maintained

Usage:

Requirements

For MacOS a newer version of nasm is required when you want to build openh264.

brew install nasm

Running

Install via CocoaPods:

platform :ios, '9.0'
pod 'Vialer-pjsip-iOS'

Contributing

See the CONTRIBUTING.md file on how to contribute to this project.

Contributors

See the CONTRIBUTORS.md file for a list of contributors to the project.

Roadmap

Changelog

The changelog can be found in the CHANGELOG.md file.

Current issues:

When using the pod as a dependency in another podspec, linting generates the following error:

The 'Pods' target has transitive dependencies that include static binaries: VialerPJSIP.framework

As a workaround you can use

pod spec lint --use-libraries

The library is a fat static library and cannot be included in an use_frameworks! enviroment at this moment. We're trying to find a solution for this and implement a way to create a dynamic library.

Future

  • Make the libarary static build for Swift only projects.
  • Staying up-to-date with PJSIP releases

Get in touch with a developer

If you want to report an issue see the CONTRIBUTING.md file for more info.

We will be happy to answer your other questions at {opensource@wearespindle.com or insert alias}

License

Vialer-pjsip-iOS is made available under the GNU General Public License v3.0 license. See the LICENSE file for more info.

Rate & Review

Great Documentation0
Easy to Use0
Performant0
Highly Customizable0
Bleeding Edge0
Responsive Maintainers0
Poor Documentation0
Hard to Use0
Slow0
Buggy0
Abandoned0
Unwelcoming Community0
100