ul

ui5-loader

An UNOFFICIAL experimental Webpack loader for SAP UI5. Together with my Babel plugin(https://github.com/MagicCube/babel-plugin-ui5), you are abel to use Webpack + Babel to build your next generation UI5 applications.

Showing:

Popularity

Downloads/wk

3

GitHub Stars

20

Maintenance

Last Commit

4yrs ago

Contributors

1

Package

Dependencies

1

Size (min+gzip)

15.8KB

License

MIT

Type Definitions

Tree-Shakeable

No?

Categories

Readme

#FORE MORE INFORMATION, PLEASE VISIT babel-plugin-ui5

ui5-loader

An UNOFFICIAL experimental Webpack loader for SAP UI5. Together with my Babel plugin(https://github.com/MagicCube/babel-plugin-ui5), you are abel to use Webpack + Babel to build your next generation UI5 applications.

Usage

1. Install babel-preset-ui5

Please refer to babel-preset-ui5.

2. Install ui5-loader

$ npm install --save-dev ui5-loader

3. Configure webpack.config.js

{
    ...
    module: {
        loaders: [
            {
                test: /\.js$/,
                exclude: /(node_modules|bower_components)/,
                loaders: [
                    "ui5-loader?sourceRoot=./src",
                    "babel-loader?sourceRoot=./src"
                ]
            }
        ]
    }
}

Rate & Review

Great Documentation0
Easy to Use0
Performant0
Highly Customizable0
Bleeding Edge0
Responsive Maintainers0
Poor Documentation0
Hard to Use0
Slow0
Buggy0
Abandoned0
Unwelcoming Community0
100