sof

sofia2

ECMAScript client for the Sofia2 IoT plattform

Showing:

Popularity

Downloads/wk

1

GitHub Stars

1

Maintenance

Last Commit

6yrs ago

Contributors

0

Package

Dependencies

0

License

ISC

Type Definitions

Tree-Shakeable

No?

Categories

Deprecated!
this package has been deprecated

Readme

Sofia2 - ECMAScript

npm version Build Status

UNDER CONSTRUCTION, COMING SOON...

The client for ECMAScript (from now simply "ES", the standard specification of the well known JavaScript language) is built over ECMAScript 6 draft standards, but using only the subset that is able to be pollyfied with and for ES3.


Always looking at the future!


By doing this, Sofia2 ECMAScript version will be able to run not only in modern browsers but also over legacy ones like Internet Explorer 8.

Use it

Because sofia2 follows the UMD, it is able to run over any module system (like CommonJS Modules on node.js, RequireJS on browsers or a simple global variable var Sofia2).

Nodejs && NPM

With npm do: npm install sofia2 --save-dev

Browsers

Include the release/sofia2.bundle.js in your document with a <script> tag or with a require sentence.

Polyfills

EcmaScript 5:

EcmaScript 6:

Build it

In order to build the ECMAScript client of Sofia2, you will need to following the next steps:

  1. Install node.js, with npm included in the setup process.
  2. Open a command prompt over the ecmascript folder.
  3. Run npm install.

A new folder release will appear, containing ol the generated files...

Thats all!

Examples

Rate & Review

Great Documentation0
Easy to Use0
Performant0
Highly Customizable0
Bleeding Edge0
Responsive Maintainers0
Poor Documentation0
Hard to Use0
Slow0
Buggy0
Abandoned0
Unwelcoming Community0
100