required_env

Corrall your environment variables, but only a little bit

Showing:

Popularity

Downloads/wk

15

GitHub Stars

2

Maintenance

Last Commit

4yrs ago

Contributors

0

Package

Dependencies

0

License

ISC

Type Definitions

Tree-Shakeable

No?

Categories

Readme

This is a way to ensure any required environment variables are set. You can also specify defaults.

Installation:

npm install required_env

Example:

var required = require('required_env');

required([
  'SOMETHING_SECRET',
  {
    var: 'DATABASE_LOCATION',
    default: 'LOCALHOST'
  }
]);

Rate & Review

Great Documentation0
Easy to Use0
Performant0
Highly Customizable0
Bleeding Edge0
Responsive Maintainers0
Poor Documentation0
Hard to Use0
Slow0
Buggy0
Abandoned0
Unwelcoming Community0
100
No reviews found
Be the first to rate

Alternatives

No alternatives found

Tutorials

No tutorials found
Add a tutorial