gr

gulp-requirejs

A small, simple, very easy wrapper around the require.js optimizer to work with gulp.js

Showing:

16 Versions

1.4.0

  • Update dependencies
  • Don't try to create file with no output (#53) (thanks @eemeli)

1.3.0

New features

  • Build directory, thanks @gmkll (#44)

Other

  • Dependency updates

1.2.1

  • Pin event-stream to 3.3.4 to prevent installing a crypto backdoor (#39)

1.2.0

  • dependency updates.
  • minimum node version increased to 6.
  • Replace deprecated new Buffer() with Buffer.from().

1.1.1

Fix an NPM packaging error.

1.1.0

  • Dependency updates.
  • Replacing gulp-util with plugin-error and vinyl.

1.0.0

Same as v1.0.0-rc2, mostly.

1.0.0-rc2

Dependency updates and replaced .npmignore with a files array in package.json.

1.0.0-rc1

No more issues, no more pull requests: time for v1.0.0!

Compared to v0.4.0 only the code style has been improved and codified in .editorconfig and .eslintrc.json.

0.4.0

This release adds:

  • Preliminary source map support (see readme for instructions)
  • Support for retrieving the r.js build report from the file object in the vinyl stream (see #21) (@docnoe)
  • r.js error reporting via the regular gulp error message system
  • Optional optimization via r.js via the optimize option

0.3.0

This version updates all dependencies to their latest versions and removes compatibility with node.js versions below 4.

0.2.0

Robin Thrift has kindly allowed me to take over the project to fix some long-standing issues. I can't fix them all at once, especially the dependency updates will have to wait until another release. For now, the issue with gulp-requirejs not being chainable in gulp is resolved.

0.1.3

0.1.2

0.1.1

0.1.0