ember-pikaday

A datepicker component for Ember CLI projects.

Showing:

37 Versions

3.0.0

💥 Breaking Change

This major version release drops support for Node.js 6 and 8 and for all Ember.js releases that happened before v3.12. Other than that there should be no other breaking changes included in this release.

🚀 Enhancement 🐛 Bug Fix 📝 Documentation 🏠 Internal Committers: 4

2.4.1

🐛 Bug Fix 🏠 Internal Committers: 2

2.4.0

🚀 Enhancement
  • #220 Remove jQuery from interactor and components (@FabHof)
📝 Documentation 🏠 Internal
  • #226 run rwjblue's release it script (@efx)
  • #225 introduce lerna-changelog (@efx)
  • #224 remove bower configuration (@efx)
  • #223 update to new repository URL (@efx)
Committers: 3

2.3.1

2.3.0

  • Cleanup scheduled task when component is torn down (Contribution by @bdollard)
  • chore: configure Prettier (Contribution by @alexlafroscia)
  • Allow minDate & maxDate to be reset (Contribution by @asjongers)
  • Update Tests (Contribution by @alexlafroscia)
  • fix: remove use of deprecated sync queue (Contribution by @alexlafroscia
New Test Helpers

The old test helpers have been deprecated in favor of a new set based around async and await, like the modern @ember/test-helpers. Please see the README for documentation on the new helpers.

The existing helpers will remain in the codebase until v3.0.0, at which time they will be removed.

2.2.6

  • Upgrade to ES6 modules (Contribution by @esbanarango)
  • add test on interactor day selection edge case (Contribution by @hakilebara)
  • set autocomplete to off as default (Contribution by @luxferresum)
  • Move ember-cli-moment-shim to dependencies (Contribution by @esbanarango)

2.2.5

  • Prevent error in run later when component was destroyed (Contribution by @Schnellesadlerauge))
  • Upgrade to ember/ember-cli 2.18.2 (Contribution by @mnutt))

2.2.4

  • Fix syntax error (Contribution by @quadstar))
  • Add ability to set a default date (Contribution by @jscn)
  • Remove arguments in component lifecycle hooks (Contribution by @jbaily4)
  • Fixes moment deprecation by using a date format (Contribution by @cah-danmonroe)

2.2.3

  • Allow binding of autocomplete attribute (Contribution by @npafundi)
  • Upgrade to Ember CLI 2.12.1 (Contribution by @leizhao4)
  • Set minDate and maxDate using a copy to avoid modifying original date (Contribution by @sandydoo)
  • Fix ember-cli-node-asset deprecation of complex imports inline (Contribution by @leizhao4)
  • Remove deprecation warning in using didUpdateAttrs (Contribution by @tsteuwer)
  • Make setDate asychronous (Contribution by @bdollard)
  • run super on willDestroy (Contribution by @devotox)
  • Prepare for FastBoot 1.0 (Contribution by @josemarluedke)

2.2.2

  • Fix infinite rendering invalidation detected (Contribution by @jedrula)
  • Fix 2.12 deprecation of arguments in component life cycle hooks (Contribution by @leizhao4)
  • Fix enforcing minDate to allow null value (Contribution by @ilucin)

2.2.1

2.2.0

2.1.0

2.0.0

2.0.0-beta.2

2.0.0-beta.1

1.1.0

1.0.0

0.14.0

0.13.0

0.12.0

0.10.0

0.9.0

0.8.0

0.7.2

0.7.1

0.7.0

0.6.0

0.5.0

0.4.0

0.3.0

0.2.1

0.2.0

0.1.0

0.0.3

0.0.2

0.0.1