dls
dot-language-server
npm i dot-language-server
dls

dot-language-server

A language server for the DOT language

by Niklas Mollenhauer

1.1.22 (see all)License:MITTypeScript:Not Found
npm i dot-language-server
Readme

dot-language-server CI Dependency Status npm downloads

A language Server for the DOT language/Graphviz.

Prerequisites

  • Node.js >=16
  • npm

Installation

npm i -g dot-language-server

If you want to request or implement new features, head over to dot-language-support.

Features

Refactorings

Refactorings Demo in Sublime Text

Usage

Visual Studio Code

TODO: There's an Extension for that.

Sublime Text

  1. Install LSP support via Install Package -> LSP
  2. Go to Preferences: LSP Settings
  3. Add this to clients:
{
    "clients": {
        "dot-language-server": {
            "command": ["dot-language-server", "--stdio"],
            "enabled": true,
            "languageId": "dot",
            "scopes": ["source.dot"],
            "syntaxes": ["Packages/Graphviz/DOT.sublime-syntax"]
        }
    }
}

Note for Windows Users: You have to append .cmd to the first entry in the command array (or, if possible, enable shell execution).

...and you're done!

Downloads/wk

145

GitHub Stars

11

LAST COMMIT

10mos ago

MAINTAINERS

1

CONTRIBUTORS

1

OPEN ISSUES

3

OPEN PRs

0
VersionTagPublished
1.1.22
latest
1mo ago
No alternatives found
No tutorials found
Add a tutorial

Rate & Review

100
No reviews found
Be the first to rate