<!DOCTYPE html><html lang="en-US"><head><link rel="stylesheet" data-href="https://fonts.googleapis.com/css2?family=DM+Mono:wght@500&amp;family=Nunito:wght@200;300;400;600;800&amp;display=swap"/><link rel="preconnect" href="https://fonts.gstatic.com" crossorigin /><meta name="viewport" content="width=device-width"/><meta charSet="utf-8"/><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"/><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"/><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"/><link rel="manifest" href="/site.webmanifest"/><link rel="mask-icon" href="/safari-pinned-tab.svg" color="#5bbad5"/><meta name="msapplication-TileColor" content="#001b37"/><meta name="theme-color" content="#ffffff"/><link rel="preload" as="image" imagesrcset="/_next/image?url=%2Fpngs%2Fopenbase-logo.v2.png&amp;w=256&amp;q=75 1x, /_next/image?url=%2Fpngs%2Fopenbase-logo.v2.png&amp;w=384&amp;q=75 2x"/><link rel="preload" as="image" imagesrcset="/_next/image?url=%2Fpngs%2Fopenbase-logo-icon.v2.png&amp;w=64&amp;q=75 1x, /_next/image?url=%2Fpngs%2Fopenbase-logo-icon.v2.png&amp;w=128&amp;q=75 2x"/><title>backbone.localstorage: Docs, Tutorials, Reviews | Openbase</title><meta content="backbone.localstorage: Docs, Tutorials, Reviews | Openbase" itemProp="name"/><meta content="backbone.localstorage: Docs, Tutorials, Reviews | Openbase" property="og:title"/><meta name="twitter:title" content="backbone.localstorage: Docs, Tutorials, Reviews | Openbase"/><meta content="backbone.localstorage documentation, tutorials, reviews, alternatives, versions, dependencies, community, and more" name="description"/><meta content="backbone.localstorage documentation, tutorials, reviews, alternatives, versions, dependencies, community, and more" property="og:description"/><meta content="backbone.localstorage documentation, tutorials, reviews, alternatives, versions, dependencies, community, and more" name="twitter:description"/><meta content="https://openbase.com/jpgs/meta-image.jpg" itemProp="image"/><meta content="https://openbase.com/jpgs/meta-image.jpg" name="image"/><link href="https://openbase.com/jpgs/meta-image.jpg" rel="image_src"/><meta content="https://openbase.com/jpgs/meta-image.jpg" property="og:image"/><meta content="https://openbase.com/jpgs/meta-image.jpg" name="twitter:image"/><meta content="en_US" property="og:locale"/><meta content="website" property="og:type"/><link rel="canonical" href="https://openbase.com/js/backbone.localstorage"/><meta content="https://openbase.com/js/backbone.localstorage" property="og:url"/><meta content="index,follow" name="robots"/><meta content="Openbase" property="og:site_name"/><meta content="345600" property="og:ttl"/><meta content="@openbase" name="twitter:site"/><meta content="summary_large_image" name="twitter:card"/><meta name="next-head-count" content="32"/><link rel="preload" href="/_next/static/css/14bc70aaef9482bd6474.css" as="style"/><link rel="stylesheet" href="/_next/static/css/14bc70aaef9482bd6474.css" data-n-g=""/><noscript data-n-css=""></noscript><script defer="" nomodule="" src="/_next/static/chunks/polyfills-020a202c55bcaa653b58.js"></script><script defer="" src="/_next/static/chunks/6731.963c5b186b5ca8dbeeee.js"></script><script defer="" src="/_next/static/chunks/6597.d0e2e283c847d93a0241.js"></script><script defer="" src="/_next/static/chunks/6888.e62eebc69313ef8d121b.js"></script><script defer="" src="/_next/static/chunks/8895.4cf762e5d9d66c5d5410.js"></script><script defer="" src="/_next/static/chunks/8363.b3932fdd83f0ee798d8a.js"></script><script defer="" src="/_next/static/chunks/4831.44b3021f8f4ccff7194f.js"></script><script defer="" src="/_next/static/chunks/286.c3606f7bc2d18ddb02f8.js"></script><script defer="" src="/_next/static/chunks/3086-91e8dbd7758a4395f80d.js"></script><script defer="" src="/_next/static/chunks/7565-907f77704ca86afed052.js"></script><script defer="" src="/_next/static/chunks/3300.1a17844855171cf27b0e.js"></script><script src="/_next/static/chunks/webpack-281135bcc331f1cfee86.js" defer=""></script><script src="/_next/static/chunks/framework-ee7f4db754ed3f3ec0b7.js" defer=""></script><script src="/_next/static/chunks/main-8e716e934957ba33fbd0.js" defer=""></script><script src="/_next/static/chunks/pages/_app-1d8623319968e5685b8a.js" defer=""></script><script src="/_next/static/chunks/2132-c72ce8ca1f58a446f013.js" defer=""></script><script src="/_next/static/chunks/9161-55ecd8d5d9a2f6abad79.js" defer=""></script><script src="/_next/static/chunks/3869-5fd501bfe83d4a5294e2.js" defer=""></script><script src="/_next/static/chunks/8956-327879b84fe68740a8b2.js" defer=""></script><script src="/_next/static/chunks/7092-62f737161c3b13170279.js" defer=""></script><script src="/_next/static/chunks/9772-0c42651c8d0d5023a4d6.js" defer=""></script><script src="/_next/static/chunks/9540-6d8d0febe676206f5322.js" defer=""></script><script src="/_next/static/chunks/3853-06826d1e360a92a15d1a.js" defer=""></script><script src="/_next/static/chunks/9926-baf077ece577f8b0fef4.js" defer=""></script><script src="/_next/static/chunks/2462-4e244347ed5a2bc439ab.js" defer=""></script><script src="/_next/static/chunks/384-2b91e2ce71cbb5f94176.js" defer=""></script><script src="/_next/static/chunks/5110-35fe5d12ba92e33d4d4f.js" defer=""></script><script src="/_next/static/chunks/2633-e31fb8c75c48cdf801d1.js" defer=""></script><script src="/_next/static/chunks/8024-059b844bea2f800587b1.js" defer=""></script><script src="/_next/static/chunks/6562-3579d7f5466f08461fad.js" defer=""></script><script src="/_next/static/chunks/8174-b281b5f19f922c05526b.js" defer=""></script><script src="/_next/static/chunks/pages/%5BpackageLang%5D/%5BpackageName%5D-7be3cc6ab66b21e86d3c.js" defer=""></script><script src="/_next/static/gz0k6u_zShmE1WJPJuwA8/_buildManifest.js" defer=""></script><script src="/_next/static/gz0k6u_zShmE1WJPJuwA8/_ssgManifest.js" defer=""></script><style data-styled="" data-styled-version="5.3.1">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</style><style data-href="https://fonts.googleapis.com/css2?family=DM+Mono:wght@500&family=Nunito:wght@200;300;400;600;800&display=swap">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</style></head><body><div id="__next"><div class="SiteWideLayout__Root-sc-imbkiq-0 fVenFb"><div class="AppBar-sc-usf7zw-0 SiteWideAppBar__Root-sc-1q657e-0 TgxKf hhYJrO SiteWideLayout__AppBar-sc-imbkiq-1 gymawJ"><div class="SiteWideAppBar__Content-sc-1q657e-1 lnddWk"><div class="SiteWideAppBar__Left-sc-1q657e-2 cXCwgr"><a class="AppBarLogo__Root-sc-1eyz6u3-0 gthhYd SiteWideAppBar__StyledLogo-sc-1q657e-5 HucBS" aria-label="go to home page" href="/"><div class="AppBarLogo__CropHack-sc-1eyz6u3-1 hgSVsh"><div class="AppBarLogo__Logo-sc-1eyz6u3-2 geJNMI"><div style="display:inline-block;max-width:100%;overflow:hidden;position:relative;box-sizing:border-box;margin:0"><div style="box-sizing:border-box;display:block;max-width:100%"><img style="max-width:100%;display:block;margin:0;border:none;padding:0" alt="" aria-hidden="true" role="presentation" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTcwIiBoZWlnaHQ9IjQwIiB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZlcnNpb249IjEuMSIvPg=="/></div><img alt="openbase logo" srcSet="/_next/image?url=%2Fpngs%2Fopenbase-logo.v2.png&amp;w=256&amp;q=75 1x, /_next/image?url=%2Fpngs%2Fopenbase-logo.v2.png&amp;w=384&amp;q=75 2x" src="/_next/image?url=%2Fpngs%2Fopenbase-logo.v2.png&amp;w=384&amp;q=75" decoding="async" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%;object-fit:cover"/></div></div></div><div class="AppBarLogo__LogoIcon-sc-1eyz6u3-3 jIpHdm"><div style="display:inline-block;max-width:100%;overflow:hidden;position:relative;box-sizing:border-box;margin:0"><div style="box-sizing:border-box;display:block;max-width:100%"><img style="max-width:100%;display:block;margin:0;border:none;padding:0" alt="" aria-hidden="true" role="presentation" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iNjAiIGhlaWdodD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"/></div><img alt="openbase logo" srcSet="/_next/image?url=%2Fpngs%2Fopenbase-logo-icon.v2.png&amp;w=64&amp;q=75 1x, /_next/image?url=%2Fpngs%2Fopenbase-logo-icon.v2.png&amp;w=128&amp;q=75 2x" src="/_next/image?url=%2Fpngs%2Fopenbase-logo-icon.v2.png&amp;w=128&amp;q=75" decoding="async" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%;object-fit:contain"/></div></div></a><a href="/"><svg xmlns="http://www.w3.org/2000/svg" width="41.338" height="40.207" viewBox="0 0 41.338 40.207" class="SiteWideAppBar__MiniLogo-sc-1q657e-6 jHGPeX"><path fill="#bfffff" d="M8.005 26.805L6.77 12.785 21.463 9.83l14.83 2.957-1.348 13.981-13.483 10.134z"></path><path fill="#2d384e" d="M21.462 8.006L36.3 12.783 21.462 36.861l-14.7-24.076z"></path></svg></a><div class="SiteWideAppBar__Actions-sc-1q657e-8 bWIwMV"><a href="/categories/js" class="Typography-sc-ye08y9-0 SiteWideAppBar__Action-sc-1q657e-7 jzJHyJ gKDxHV">Categories</a><a href="/leaderboard" class="Typography-sc-ye08y9-0 SiteWideAppBar__Action-sc-1q657e-7 jzJHyJ gKDxHV">Leaderboard</a></div></div><div role="combobox" aria-expanded="false" aria-haspopup="listbox" aria-labelledby="downshift-65-label" class="SearchBar__Container-sc-lqpe6t-0 fgLRCN SiteWideAppBar__StyledSearchBar-sc-1q657e-3 hZVjX toolbar"><div class="SearchBar__ComboBox-sc-lqpe6t-1 iIzwVz toolbar "><div class="SearchBar__ListboxStyled-sc-lqpe6t-2 buslQa"><div class="SearchBar__ListboxButtonContainer-sc-lqpe6t-3 fcbhHA"><button class="SearchBar__ListboxButtonStyled-sc-lqpe6t-4 hSutkM" id="headlessui-listbox-button-undefined" type="button" aria-haspopup="true" aria-expanded="false"><div class="SearchBar__StyledSelectedIcon-sc-lqpe6t-5 Sddlr"><div style="display:inline-block;max-width:100%;overflow:hidden;position:relative;box-sizing:border-box;margin:0"><div style="box-sizing:border-box;display:block;max-width:100%"><img style="max-width:100%;display:block;margin:0;border:none;padding:0" alt="" aria-hidden="true" role="presentation" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjUiIGhlaWdodD0iMjUiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"/></div><noscript><img srcSet="/_next/image?url=%2Fsvgs%2Fregistries%2Falt%2FJS.svg&amp;w=32&amp;q=75 1x, /_next/image?url=%2Fsvgs%2Fregistries%2Falt%2FJS.svg&amp;w=64&amp;q=75 2x" src="/_next/image?url=%2Fsvgs%2Fregistries%2Falt%2FJS.svg&amp;w=64&amp;q=75" decoding="async" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" decoding="async" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/></div></div><svg xmlns="http://www.w3.org/2000/svg" width="8.686" height="14.785" viewBox="0 0 8.686 14.785" class="SearchBar__ArrowIconStyled-sc-lqpe6t-7 loptHP"><path fill="currentColor" d="M8.45 6.816L1.871.236a.811.811 0 00-1.144 0L.242.721a.81.81 0 000 1.144L5.767 7.39.236 12.921a.811.811 0 000 1.144l.485.484a.811.811 0 001.144 0L8.45 7.964a.816.816 0 000-1.148z"></path></svg></button></div></div><input placeholder="Search for any JavaScript undefined or category" aria-autocomplete="list" aria-labelledby="downshift-65-label" autoComplete="off" value="" id="downshift-65-input" class="SearchBar__Input-sc-lqpe6t-11 hZYIvo"/><div class="SearchBar__Placeholder-sc-lqpe6t-16 ikCccd"><svg width="18.748" height="18.749" class="SearchBar__StyledSearchIcon-sc-lqpe6t-17 gWhwyp"><path d="M12.52 2.145a7.337 7.337 0 10-1 11.207 1.545 1.545 0 00.419.778l4.16 4.165a1.552 1.552 0 002.194-2.195l-4.165-4.167a1.55 1.55 0 00-.777-.418 7.344 7.344 0 00-.831-9.37zm-1.315 9.061a5.477 5.477 0 110-7.745 5.483 5.483 0 010 7.745z"></path></svg></div></div></div><div class="SiteWideAppBar__Right-sc-1q657e-4 keeUsZ"></div><div class="SiteWideAppBar__MobileMenuContainer-sc-1q657e-10 eAiHai"><button aria-label="mobile menu button" class="HamburgerMenuButton__Root-sc-76rr63-0 etAGHJ SiteWideAppBar__MobileMenuButton-sc-1q657e-11 jcFXEP"><span></span><span></span><span></span></button><div class="PageDrawer__Root-sc-199y67j-0 kGqlyz AppBarMobileMenu__Root-sc-1h6j6a6-0 hBdsdZ " aria-hidden="true"><a href="/"><svg xmlns="http://www.w3.org/2000/svg" width="122.344" height="27.38" viewBox="0 0 122.344 27.38" class="AppBarMobileMenu__StyledLogo-sc-1h6j6a6-1 eiGPNd"><defs><style>.openbase-logo-outline_svg__cls-1{fill:#bfffff}</style></defs><g id="openbase-logo-outline_svg__Logo" transform="translate(-753.829 -645.272)"><path id="openbase-logo-outline_svg__Path_767" d="M7.034-6.838c2.933 0 3.742-.873 3.742-4.133 0-3.2-.809-4.284-3.742-4.284s-3.921 1.039-3.921 4.239c.001 3.261.987 4.178 3.921 4.178zM1.465-10.97q0-5.848 5.569-5.848T12.6-10.97q0 5.837-5.569 5.837-5.544-.001-5.566-5.837zM16.42-7.632a10.777 10.777 0 003.168.592c2.328-.309 3.521-.7 3.521-4.064 0-2.993-.823-3.8-3.5-4.1a22.093 22.093 0 00-3.189.233zm-1.944-8.707a23.82 23.82 0 014.812-.479q5.625 0 5.625 5.558 0 6.137-5.659 6.137a10.442 10.442 0 01-2.834-.557v4.79h-1.944zm21.562 6.193h-7.983c0 3.059 3.169 3.505 4.78 3.432a27.23 27.23 0 002.988-.186v1.592a17.261 17.261 0 01-3.66.308c-3.943 0-5.935-2.117-5.935-6.1q0-5.714 5.6-5.714c3.434-.004 4.752 2.599 4.21 6.668zm-7.983-1.615h6.4c.178-2.718-.926-3.564-2.985-3.564-1.977-.001-3.281.846-3.415 3.564zm10.36 6.639v-11.7h1.113l.387 1.406a9.4 9.4 0 014.537-1.406q3.821 0 3.821 3.687v8.009h-1.677v-8.042c0-1.738-.82-2.066-2.444-2.061s-2.346.478-4 1.466v8.638zM52.479-6.9a14.14 14.14 0 002.845.221c3.193 0 4.167-1.244 4.167-4.653 0-2.948-.951-3.778-3.9-3.778a10.03 10.03 0 00-3.113.577zM50.7-21.051l1.777-.025v4.79a11.523 11.523 0 013.124-.532q5.547 0 5.547 5.614 0 6.082-5.826 6.082A20.845 20.845 0 0150.7-5.6zm11.763 12.4q0-3.375 4.968-3.375a25.843 25.843 0 013.249.246v-1.437c0-1.715-1.233-2.037-3.572-2a13.072 13.072 0 00-3.7.557v-1.6a13.072 13.072 0 013.7-.557q5.213 0 5.213 3.743v7.953h-.711l-.85-.8a10.5 10.5 0 01-3.895.8q-4.4-.001-4.4-3.532zm4.968-1.932c-2.532 0-3.364.372-3.364 1.932 0 1.708.643 1.976 2.8 1.976a8.764 8.764 0 003.817-.89v-2.79a24.4 24.4 0 00-3.251-.23zm7.319 4.906v-1.645a12.414 12.414 0 004.055.668c2.458 0 3.365-.25 3.365-1.81 0-1.262-.588-1.894-2.407-1.894h-1.892q-3.676 0-3.676-3.119 0-3.342 4.868-3.342a14.646 14.646 0 014.043.557v1.707a12.381 12.381 0 00-4.043-.668c-2.465 0-3.17.187-3.17 1.746 0 1.337.429 1.694 2.1 1.694h1.894c2.6 0 3.778 1.313 3.778 3.318q0 3.342-4.857 3.342a14.686 14.686 0 01-4.056-.556zm20.09-4.639H86.7c.389 2.476 1.343 3.64 4.952 3.64a21.9 21.9 0 003-.221v1.442a18.145 18.145 0 01-3.765.334q-5.915 0-5.915-5.982 0-5.714 5.6-5.714c3.44-.001 4.812 2.43 4.27 6.499zm-8.14-1.723h6.63c.178-2.718-1.224-3.192-3.091-3.192-1.589 0-3.401.474-3.539 3.192z" class="openbase-logo-outline_svg__cls-1" transform="translate(781.217 670.29)"></path><g id="openbase-logo-outline_svg__Group_19" transform="translate(753.829 645.272)"><path id="openbase-logo-outline_svg__Path_3" fill="#bfffff" d="M15.865 1.372L21 10.3l-6.687 6.707-9.175 2.483L0 10.561 4.5 0z" opacity="0.004" transform="rotate(-150 12.763 11.253)"></path><path id="openbase-logo-outline_svg__Exclusion_1" d="M10 19.639L.841 12.767 0 3.225 10 0l10.093 3.225-.919 9.517L10 19.639zm0-18.575L1.1 3.953 10 19.635l8.994-15.68L10 1.064z" class="openbase-logo-outline_svg__cls-1" transform="translate(4.295 5.493)"></path></g></g></svg></a><div class="AppBarMobileMenu__Header-sc-1h6j6a6-5 fFSEVR">Choose the right package every time</div><div class="AppBarMobileMenu__Description-sc-1h6j6a6-6 bbSPYl">Openbase helps you choose packages with reviews, metrics &amp; categories.<!-- --> <a class="AppBarMobileMenu__LearnMore-sc-1h6j6a6-7 dxjyqj">Learn more</a></div><div class="AppBarMobileMenu__Actions-sc-1h6j6a6-2 buVlwy"><a class="Typography-sc-ye08y9-0 AppBarMobileMenu__Action-sc-1h6j6a6-3 jzJHyJ fwsCLb">Categories</a><a class="Typography-sc-ye08y9-0 AppBarMobileMenu__Action-sc-1h6j6a6-3 jzJHyJ fwsCLb">Leaderboard</a><button class="Typography-sc-ye08y9-0 AppBarMobileMenu__Action-sc-1h6j6a6-3 jzJHyJ fwsCLb">Feedback</button></div><div class="AppBarMobileMenu__SignupWithGithubButton-sc-1h6j6a6-11 cIHqco"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 30 30" data-name="github icon" class="AppBarMobileMenu__StyledGithubIcon-sc-1h6j6a6-12 cHlJvV"><path d="M14.8 0a14.8 14.8 0 00-4.679 28.849c.739.137.978-.322.978-.712v-2.755c-4.118.9-4.975-1.747-4.975-1.747a3.921 3.921 0 00-1.644-2.166c-1.343-.919.1-.9.1-.9A3.107 3.107 0 016.854 22.1a3.151 3.151 0 004.308 1.23 3.141 3.141 0 01.94-1.979c-3.287-.376-6.744-1.646-6.744-7.316a5.729 5.729 0 011.525-3.973 5.324 5.324 0 01.144-3.918s1.243-.4 4.072 1.517a14.031 14.031 0 017.412 0c2.826-1.914 4.067-1.517 4.067-1.517a5.319 5.319 0 01.146 3.918 5.714 5.714 0 011.523 3.973c0 5.686-3.463 6.938-6.759 7.3a3.538 3.538 0 011.012 2.74v4.062c0 .394.237.856.988.711A14.806 14.806 0 0014.8 0z" data-name="github icon" fill="currentColor"></path></svg><span class="AppBarMobileMenu__SignupText-sc-1h6j6a6-4 gLWHgV">Sign up with GitHub</span></div><div class="AppBarMobileMenu__TermsText-sc-1h6j6a6-8 hFOfOO">By signing up, you agree to our<a href="/legal/terms" class="AppBarMobileMenu__TermsLink-sc-1h6j6a6-9 eVjxmH"> <!-- -->terms of service</a> <!-- -->and<!-- --> <a href="/legal/privacy" class="AppBarMobileMenu__TermsLink-sc-1h6j6a6-9 eVjxmH">privacy policy</a></div><div class="AppBarMobileMenu__LoginText-sc-1h6j6a6-10 gHtNRq">Log In</div><div class="AppBarMobileMenu__MenuBottom-sc-1h6j6a6-13 drRLpu"><div class="AppBarMobileMenu__MenuBottomItems-sc-1h6j6a6-14 hGExLZ"><a href="/about/openbase" class="AppBarMobileMenu__MenuBottomLink-sc-1h6j6a6-15 jfBuAP">What&#x27;s Openbase?</a><span class="AppBarMobileMenu__Delimiter-sc-1h6j6a6-16 euVwNb">•</span><a href="/about" class="AppBarMobileMenu__MenuBottomLink-sc-1h6j6a6-15 jfBuAP">Help</a><span class="AppBarMobileMenu__Delimiter-sc-1h6j6a6-16 euVwNb">•</span><a class="AppBarMobileMenu__MenuBottomLink-sc-1h6j6a6-15 jfBuAP">Send Feedback</a></div></div></div></div></div></div><div class="SiteWideLayout__Content-sc-imbkiq-2 BCNxm"><div class="PackageLayout__Header-sc-1cul6dm-0 ijIAJc"><div class="PackageHeader__Root-sc-1m3dzp1-0 fjHOoN PackageLayout__StyledPackageHeader-sc-1cul6dm-1 iFITaA"><div class="PackageHeader__ContentContainer-sc-1m3dzp1-1 cgCoCq"><div class="PackageIcon__PackageIconWrapper-sc-qogin6-0 tcuOs PackageHeader__StyledPackageIcon-sc-1m3dzp1-5 kYWywX"><div class="PackageIcon__IconGeneratedImage-sc-qogin6-1 HViWl"><div class="GradientIcon__Root-sc-110bq98-0 hDhlLB" style="background:linear-gradient(225deg, #38EF7D 0%, #11998E 100%)"></div><svg viewBox="0 0 113 50" class="PackageIcon__PackageNameAbbreviationSvg-sc-qogin6-2 hrgzxz"><text x="0" y="40" class="PackageIcon__PackageNameAbbreviationText-sc-qogin6-3 Gkvsa">bl</text></svg></div></div><div class="PackageHeader__Content-sc-1m3dzp1-6 ewPGGm"><div class="PackageHeader__Top-sc-1m3dzp1-7 dITOAs"><div class="PackageHeader__InfoContainer-sc-1m3dzp1-8 iWpYME"><div class="PackageHeader__Info-sc-1m3dzp1-9 fljlph"><h1 class="Typography-sc-ye08y9-0 PackageHeader__PackageName-sc-1m3dzp1-10 jzJHyJ khWcZg"><span class="PackageHeader__PackageNameText-sc-1m3dzp1-11 hAPQXB">backbone.localstorage</span></h1><div class="PackageHeader__AfterNameLinks-sc-1m3dzp1-12 bDiUJY" style="opacity:1"><div class="PackageHeader__NoCollision-sc-1m3dzp1-13 hVElSK"><span></span><div class="InfoPart__Root-sc-hsb0t4-2 dVvOBY"><div aria-hidden="true" class="InfoPart__Delimiter-sc-hsb0t4-1 pxFgj">●</div><span class="Typography-sc-ye08y9-0 InfoPart__Text-sc-hsb0t4-0 jzJHyJ VSzXV">by <!-- -->Jerome Gravel-Niquet</span></div><div class="InfoPart__Root-sc-hsb0t4-2 dVvOBY"><div aria-hidden="true" class="InfoPart__Delimiter-sc-hsb0t4-1 pxFgj">●</div><a href="/js/backbone.localstorage/versions" class="Typography-sc-ye08y9-0 InfoPart__Text-sc-hsb0t4-0 jzJHyJ iHttdH">2.1.0<!-- --> (see all)</a></div><div class="InfoPart__Root-sc-hsb0t4-2 dVvOBY"><div aria-hidden="true" class="InfoPart__Delimiter-sc-hsb0t4-1 pxFgj">●</div><button class="Typography-sc-ye08y9-0 InfoPart__Text-sc-hsb0t4-0 jzJHyJ iHttdH">Claim This Page</button></div></div></div></div><h2 class="Typography-sc-ye08y9-0 PackageHeader__Description-sc-1m3dzp1-15 jzJHyJ cKPGuP" style="opacity:1">A localStorage adapter for Backbone.js</h2></div><div class="PackageHeader__LinksContainer-sc-1m3dzp1-16 hoDfjH"><div class="PackageHeader__Links-sc-1m3dzp1-18 hIndWJ"><div class="InfoPart__Root-sc-hsb0t4-2 dVvOBY PackageHeader__LinksInfoPart-sc-1m3dzp1-17 jgGvig"><div aria-hidden="true" class="InfoPart__Delimiter-sc-hsb0t4-1 pxFgj">●</div><a href="https://www.npmjs.com/package/backbone.localstorage" target="_blank" rel="nofollow noopener" class="Typography-sc-ye08y9-0 InfoPart__Text-sc-hsb0t4-0 jzJHyJ iHttdH">npm</a></div><div class="InfoPart__Root-sc-hsb0t4-2 dVvOBY PackageHeader__LinksInfoPart-sc-1m3dzp1-17 jgGvig"><div aria-hidden="true" class="InfoPart__Delimiter-sc-hsb0t4-1 pxFgj">●</div><a href="https://github.com/jeromegn/Backbone.localStorage" target="_blank" rel="nofollow noopener" class="Typography-sc-ye08y9-0 InfoPart__Text-sc-hsb0t4-0 jzJHyJ iHttdH">GitHub</a></div><div class="InfoPart__Root-sc-hsb0t4-2 dVvOBY PackageHeader__LinksInfoPart-sc-1m3dzp1-17 jgGvig"><div aria-hidden="true" class="InfoPart__Delimiter-sc-hsb0t4-1 pxFgj">●</div><a href="https://www.jsdelivr.com/package/npm/backbone.localstorage" target="_blank" rel="nofollow noopener" class="Typography-sc-ye08y9-0 InfoPart__Text-sc-hsb0t4-0 jzJHyJ iHttdH">CDN</a></div><div class="PackageLangIcon__Root-sc-tueenb-0 cDcNdN PackageHeader__LanguageIcon-sc-1m3dzp1-19 czmOsb"><svg xmlns="http://www.w3.org/2000/svg" width="23" height="23" viewBox="0 0 23 23" class="PackageLangIcon__Svg-sc-tueenb-1 bQuWvz"><path fill="currentColor" d="M21 23H2a2 2 0 01-2-2V2a2 2 0 012-2h19a2 2 0 012 2v19a2 2 0 01-2 2zm-5.52-5.392l-1.767 1.022a4.122 4.122 0 003.951 2.216 4.074 4.074 0 002.571-.779 2.758 2.758 0 001.025-2.243c0-1.818-1.057-2.627-2.883-3.409l-.542-.232c-.906-.393-1.333-.651-1.333-1.318a.946.946 0 011.039-.93 1.481 1.481 0 011.394.93l1.689-1.085a3.2 3.2 0 00-3.083-1.735 2.9 2.9 0 00-3.177 2.866c0 1.9 1.251 2.694 2.6 3.27l.542.232c.986.431 1.58.691 1.58 1.441 0 .64-.591 1.069-1.472 1.069a2.379 2.379 0 01-2.134-1.315zm-7.672.185l-1.766 1.069A3.355 3.355 0 009.3 20.846a3.293 3.293 0 002.34-.792 3.256 3.256 0 00.9-2.478V10.17h-2.17v7.375c0 .968-.337 1.364-1.162 1.364-.77 0-1.076-.542-1.4-1.116z"></path></svg></div></div></div></div><div class="PackageHeader__Actions-sc-1m3dzp1-22 kgJdFU"><button type="button" class="Pill__Root-sc-1t99j9w-0 dQDFEV PackageHeader__ActionPill-sc-1m3dzp1-20 eQwNOl"><svg xmlns="http://www.w3.org/2000/svg" viewBox="-2 -2 34 34" height="12" width="12"><path fill="currentColor" d="M30.342 10.752a1.607 1.607 0 00-1.391-1.084L20.17 8.89 16.7.959a1.633 1.633 0 00-2.975 0L10.253 8.89l-8.783.778a1.612 1.612 0 00-1.391 1.084 1.556 1.556 0 00.472 1.678l6.639 5.682-1.958 8.414a1.559 1.559 0 00.629 1.63 1.646 1.646 0 001.777.077l7.573-4.419 7.571 4.419a1.649 1.649 0 001.779-.077 1.559 1.559 0 00.629-1.63l-1.957-8.414 6.639-5.682a1.556 1.556 0 00.472-1.678zM15.357 23.727" data-name="star icon"></path></svg><span class="Typography-sc-ye08y9-0 PackageHeader__ActionPillLabel-sc-1m3dzp1-24 jzJHyJ cKgbXc">Rate</span></button><button class="PackageHeader__MotionAddPackageButton-sc-1m3dzp1-26 jFnrhz PackageHeader__ActionPill-sc-1m3dzp1-20 eQwNOl" type="button"><svg xmlns="http://www.w3.org/2000/svg" width="12" height="12" viewBox="0 0 16.604 13.082" class="PackageHeader__AddPackageButtonIcon-sc-1m3dzp1-25 gHUZhF"><g fill="currentColor" stroke="currentColor" stroke-linecap="round" stroke-width="2"><path d="M8.215 8.388h7.388M11.909 4.694v7.388M1 8.388h4.061M1 4.694h7.31M1 1h11.371"></path></g></svg><span class="Typography-sc-ye08y9-0 PackageHeader__ActionPillLabel-sc-1m3dzp1-24 jzJHyJ cKgbXc">Save</span></button><button class="PackageRegistryInstall__Root-sc-11zyb96-0 iZYeou PackageHeader__RegistryInstall-sc-1m3dzp1-21 leDMYw" title="npm i backbone.localstorage"><div class="PackageRegistryInstall__TextContainer-sc-11zyb96-1 gXILRx"><span class="PackageRegistryInstall__Text-sc-11zyb96-2 bQInuv">npm i backbone.localstorage</span></div><svg xmlns="http://www.w3.org/2000/svg" width="34" height="27" viewBox="0 0 34 27" class="PackageRegistryInstall__StyledCopyIcon-sc-11zyb96-3 dnZNJN"><path fill="#11ece5" d="M0 0h20.5A13.5 13.5 0 0134 13.5 13.5 13.5 0 0120.5 27H0V0z"></path><path fill="#1d2737" d="M16.624 21.189v-1.191h1.665v-1.487h1.329v2.082a.633.633 0 01-.665.6zm-5.161 0v-1.191h3.577v1.191zm-3.909 0a.633.633 0 01-.665-.6v-2.078h1.329v1.487h1.663v1.191zm4.123-3.571a.633.633 0 01-.665-.595V6.906a.633.633 0 01.665-.595h11.3a.633.633 0 01.665.595v10.117a.633.633 0 01-.665.595zm.665-1.191h9.973V7.502h-9.974zm-5.453.709v-3.2h1.329v3.2zm0-4.576v-2.083a.633.633 0 01.665-.595h2.327v1.189H8.218v1.489z"></path></svg></button></div></div></div><div class="Tabs__Root-sc-vvd2k-0 eEMAbG PackageHeaderDesktopNav__Root-sc-1cv2nvg-1 brhutU PackageHeader__DesktopNav-sc-1m3dzp1-2 bctnL"><a id="overview" href="/js/backbone.localstorage" class="Tab__Root-sc-1m49rub-0 ffFeXL PackageHeaderDesktopNav__Tab-sc-1cv2nvg-0 dVvwiw" selected=""><h2 class="PackageHeaderDesktopNav__Selected-sc-1cv2nvg-2 bBapph">Overview</h2><div class="UnderGlowBeam__Root-sc-q1uo66-0 lkUvWC"></div></a><a id="documentation" href="/js/backbone.localstorage/documentation" class="Tab__Root-sc-1m49rub-0 eCMlJK PackageHeaderDesktopNav__Tab-sc-1cv2nvg-0 dVvwiw">Documentation</a><a id="tutorials" href="/js/backbone.localstorage/tutorials" class="Tab__Root-sc-1m49rub-0 eCMlJK PackageHeaderDesktopNav__Tab-sc-1cv2nvg-0 dVvwiw">Tutorials</a><a id="reviews" href="/js/backbone.localstorage/reviews" class="Tab__Root-sc-1m49rub-0 eCMlJK PackageHeaderDesktopNav__Tab-sc-1cv2nvg-0 dVvwiw">Reviews</a><a id="maintenance" href="/js/backbone.localstorage/maintenance" class="Tab__Root-sc-1m49rub-0 eCMlJK PackageHeaderDesktopNav__Tab-sc-1cv2nvg-0 dVvwiw">Maintenance</a><a id="dependencies" href="/js/backbone.localstorage/dependencies" class="Tab__Root-sc-1m49rub-0 eCMlJK PackageHeaderDesktopNav__Tab-sc-1cv2nvg-0 dVvwiw">Dependencies</a><a id="versions" href="/js/backbone.localstorage/versions" class="Tab__Root-sc-1m49rub-0 eCMlJK PackageHeaderDesktopNav__Tab-sc-1cv2nvg-0 dVvwiw">Versions</a><a id="alternatives" href="/js/backbone.localstorage/alternatives" class="Tab__Root-sc-1m49rub-0 eCMlJK PackageHeaderDesktopNav__Tab-sc-1cv2nvg-0 dVvwiw">Alternatives</a></div><span class="Typography-sc-ye08y9-0 PackageHeader__MobileNavToggle-sc-1m3dzp1-3 jzJHyJ EQTlv">Showing:<!-- --> <button class="PackageHeader__MobileNavMenuButton-sc-1m3dzp1-4 GhnZk">Overview<!-- --> <svg xmlns="http://www.w3.org/2000/svg" width="6" height="6" viewBox="0 0 8.686 14.785" class="PackageHeader__MobileMenuIcon-sc-1m3dzp1-27 bvCymX"><path fill="currentColor" d="M8.45 6.816L1.871.236a.811.811 0 00-1.144 0L.242.721a.81.81 0 000 1.144L5.767 7.39.236 12.921a.811.811 0 000 1.144l.485.484a.811.811 0 001.144 0L8.45 7.964a.816.816 0 000-1.148z"></path></svg></button></span></div></div><div class="PackageLayout__Content-sc-1cul6dm-2 laqUu"><div class="packageName__AllQuickInsightTilesContainer-sc-13pfqk6-0 igIwv"><div class="packageName__QuickInsightTileContainer-sc-13pfqk6-1 dHFnNZ"><span class="Typography-sc-ye08y9-0 packageName__StyledPackagePageHeader-sc-13pfqk6-2 packageName__QuickInsightTitle-sc-13pfqk6-3 jzJHyJ bBfEtb hKcsTw"><h2 class="PackagePageHeader-sc-ix6jqz-0 gRLNGO">Popularity</h2></span><div class="PackageQuickInsightPopularityCard__Root-sc-a8r8th-0 gVzrLQ packageName__QuickInsightTile-sc-13pfqk6-5 eeSlPc"><div class="PackageQuickInsightPopularityCard__DownloadsContainer-sc-a8r8th-1 lebcta"><div class="PackageQuickInsightPopularityCard__InfoContainer-sc-a8r8th-3 egQxYc"><h3 class="InCardHeader-sc-117q0r-0 PackageQuickInsightPopularityCard__Header-sc-a8r8th-6 RfhVJ cueHOv">Downloads/wk</h3><span class="Typography-sc-ye08y9-0 PackageQuickInsightPopularityCard__InfoText-sc-a8r8th-7 jzJHyJ hrpiKA">4.5K</span></div><div class="PackageQuickInsightPopularityCard__LineChartContainer-sc-a8r8th-4 hcgJkE"><div class="PackageQuickInsightPopularityCard__ForceWidthContainer-sc-a8r8th-5 eA-DATX"><div class="recharts-responsive-container" style="width:100%;height:100%"></div></div></div></div><div class="PackageQuickInsightPopularityCard__GitHubStarsContainer-sc-a8r8th-2 hVycbM"><div class="PackageQuickInsightPopularityCard__InfoContainer-sc-a8r8th-3 egQxYc"><h3 class="InCardHeader-sc-117q0r-0 PackageQuickInsightPopularityCard__Header-sc-a8r8th-6 RfhVJ cueHOv">GitHub Stars</h3><span class="Typography-sc-ye08y9-0 PackageQuickInsightPopularityCard__InfoText-sc-a8r8th-7 jzJHyJ hrpiKA">1.9K</span></div><div class="PackageQuickInsightPopularityCard__LineChartContainer-sc-a8r8th-4 hcgJkE"><div class="PackageQuickInsightPopularityCard__ForceWidthContainer-sc-a8r8th-5 eA-DATX"><div class="recharts-responsive-container" style="width:100%;height:100%"></div></div></div></div></div></div><div class="packageName__QuickInsightTileContainer-sc-13pfqk6-1 dHFnNZ"><span class="Typography-sc-ye08y9-0 packageName__StyledPackagePageHeader-sc-13pfqk6-2 packageName__QuickInsightTitle-sc-13pfqk6-3 jzJHyJ bBfEtb hKcsTw"><a href="/js/backbone.localstorage/maintenance"><h2 class="PackagePageHeader-sc-ix6jqz-0 gRLNGO">Maintenance</h2></a><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 22 22" href="/js/backbone.localstorage/maintenance" class="packageName__StyledEnterArrowIcon-sc-13pfqk6-4 cILUSJ"><g stroke="currentColor"><g fill="none" transform="rotate(90 11 11)"><circle cx="11" cy="11" r="11" stroke="none"></circle><circle cx="11" cy="11" r="10.5"></circle></g><path fill="currentColor" stroke-linecap="round" stroke-linejoin="bevel" d="M9.784 15.492l-.476-.476 4.13-4.124-4.125-4.124.471-.476 4.6 4.6z"></path></g></svg></span><div class="PackageQuickInsightMaintenanceCard__Root-sc-k9jrim-0 eVCPcR packageName__QuickInsightTile-sc-13pfqk6-5 eeSlPc"><div class="PackageQuickInsightMaintenanceCard__CommitsContainer-sc-k9jrim-1 gHJSCu"><div class="PackageQuickInsightMaintenanceCard__InfoPart-sc-k9jrim-6 bCNIPO"><h3 class="InCardHeader-sc-117q0r-0 PackageQuickInsightMaintenanceCard__Header-sc-k9jrim-5 RfhVJ iJNdId">Last Commit</h3><span class="Typography-sc-ye08y9-0 PackageQuickInsightMaintenanceCard__InfoText-sc-k9jrim-7 jzJHyJ gykqoi">1yr<span> ago</span></span></div><div class="PackageQuickInsightMaintenanceCard__BarChartContainer-sc-k9jrim-3 jdaWQR"><div class="PackageQuickInsightMaintenanceCard__ForceWidthContainer-sc-k9jrim-4 iAgCQH"><div class="recharts-responsive-container" style="width:100%;height:100%"></div></div></div></div><div class="PackageQuickInsightMaintenanceCard__ContributorsContainer-sc-k9jrim-2 fZDeID"><div class="PackageQuickInsightMaintenanceCard__InfoPart-sc-k9jrim-6 bCNIPO"><h3 class="InCardHeader-sc-117q0r-0 PackageQuickInsightMaintenanceCard__Header-sc-k9jrim-5 RfhVJ iJNdId">Contributors</h3><span class="Typography-sc-ye08y9-0 PackageQuickInsightMaintenanceCard__InfoText-sc-k9jrim-7 jzJHyJ gykqoi">70</span></div></div></div></div><div class="packageName__QuickInsightTileContainer-sc-13pfqk6-1 dHFnNZ"><span class="Typography-sc-ye08y9-0 packageName__StyledPackagePageHeader-sc-13pfqk6-2 packageName__QuickInsightTitle-sc-13pfqk6-3 jzJHyJ bBfEtb hKcsTw"><h2 class="PackagePageHeader-sc-ix6jqz-0 gRLNGO">Package</h2></span><div class="PackageQuickInsightPackageCard__Root-sc-4fkb9t-0 ObZBq packageName__QuickInsightTile-sc-13pfqk6-5 eeSlPc"><div class="PackageQuickInsightPackageCard__TopInfo-sc-4fkb9t-1 bVVqvk"><div><h3 class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__Header-sc-4fkb9t-3 jzJHyJ bfakBU">Dependencies</h3><a href="/js/backbone.localstorage/dependencies" class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__NumStat-sc-4fkb9t-4 jzJHyJ bssCUc">0</a></div></div><div class="PackageQuickInsightPackageCard__BottomInfo-sc-4fkb9t-2 KJvlJ"><div class="PackageQuickInsightPackageCard__InfoRow-sc-4fkb9t-5 fGOSrk"><h3 class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__Header-sc-4fkb9t-3 PackageQuickInsightPackageCard__InfoHeader-sc-4fkb9t-6 jzJHyJ bfakBU ffqtFT">License</h3><div class="PackageQuickInsightPackageCard__LevelInfoContainer-sc-4fkb9t-7 kRLgPf"><span class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__LevelInfo-sc-4fkb9t-8 jzJHyJ efOhct">MIT</span></div></div><div class="PackageQuickInsightPackageCard__InfoRow-sc-4fkb9t-5 fGOSrk"><h3 class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__Header-sc-4fkb9t-3 PackageQuickInsightPackageCard__InfoHeader-sc-4fkb9t-6 jzJHyJ bfakBU ffqtFT">Type Definitions</h3><div class="PackageQuickInsightPackageCard__LevelInfoContainer-sc-4fkb9t-7 kRLgPf"><a target="_blank" rel="nofollow noopener" href="https://npmjs.com/package/true" class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__LevelInfo-sc-4fkb9t-8 jzJHyJ bzbJCc">DefinitelyTyped</a></div></div><div class="PackageQuickInsightPackageCard__InfoRow-sc-4fkb9t-5 fGOSrk"><h3 class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__Header-sc-4fkb9t-3 PackageQuickInsightPackageCard__InfoHeader-sc-4fkb9t-6 jzJHyJ bfakBU ffqtFT">Tree-Shakeable</h3><div class="PackageQuickInsightPackageCard__LevelInfoContainer-sc-4fkb9t-7 kRLgPf"><span class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__LevelInfo-sc-4fkb9t-8 jzJHyJ bzeqiF">No</span><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 14 18" class="PackageQuickInsightPackageCard__StyledInfoIcon-sc-4fkb9t-9 cuHSHX"><g transform="translate(-1312 -518)"><circle cx="7" cy="7" r="7" fill="currentColor" transform="translate(1312 519)"></circle><text fill="#090f19" font-family="Nunito-Black, Nunito" font-size="13" font-weight="800" transform="translate(1316 531)"><tspan x="0" y="0">?</tspan></text></g></svg></div></div><div class="PackageQuickInsightPackageCard__InfoRow-sc-4fkb9t-5 fGOSrk"><h3 class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__Header-sc-4fkb9t-3 PackageQuickInsightPackageCard__InfoHeader-sc-4fkb9t-6 jzJHyJ bfakBU ffqtFT">Categories</h3><div class="PackageQuickInsightPackageCard__LevelInfoContainer-sc-4fkb9t-7 kRLgPf"><button class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__SuggestCategories-sc-4fkb9t-12 jzJHyJ cftwrh">Suggest Categories</button></div><span class="Typography-sc-ye08y9-0 PackageQuickInsightPackageCard__Categories-sc-4fkb9t-10 jzJHyJ fyGoQr"></span></div></div></div></div><div class="packageName__QuickInsightTileContainer-sc-13pfqk6-1 dHFnNZ"><span class="Typography-sc-ye08y9-0 packageName__StyledPackagePageHeader-sc-13pfqk6-2 packageName__QuickInsightTitle-sc-13pfqk6-3 jzJHyJ bBfEtb hKcsTw"><a href="/js/backbone.localstorage/reviews"><h2 class="PackagePageHeader-sc-ix6jqz-0 gRLNGO">Reviews</h2></a><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 22 22" href="/js/backbone.localstorage/reviews" class="packageName__StyledEnterArrowIcon-sc-13pfqk6-4 cILUSJ"><g stroke="currentColor"><g fill="none" transform="rotate(90 11 11)"><circle cx="11" cy="11" r="11" stroke="none"></circle><circle cx="11" cy="11" r="10.5"></circle></g><path fill="currentColor" stroke-linecap="round" stroke-linejoin="bevel" d="M9.784 15.492l-.476-.476 4.13-4.124-4.125-4.124.471-.476 4.6 4.6z"></path></g></svg></span><div class="PackageQuickInsightReviewsCard__Root-sc-1fkhhep-0 dTFttK packageName__QuickInsightTile-sc-13pfqk6-5 eeSlPc"><div class="PackageQuickInsightReviewsCard__Content-sc-1fkhhep-1 dZtWRB"><a type="button" class="Pill__Root-sc-1t99j9w-0 dQDFEV PackageQuickInsightReviewsCard__BeFirstPill-sc-1fkhhep-14 izDtaa">Be the first to rate</a></div></div></div></div><div class="packageName__Contents-sc-13pfqk6-8 UjdTZ"><div class="packageName__LeftContentContainer-sc-13pfqk6-6 bMGrYh"><div class="packageName__ReadMeContainer-sc-13pfqk6-11 gXCRWh"><span class="Typography-sc-ye08y9-0 packageName__StyledPackagePageHeader-sc-13pfqk6-2 packageName__ReadmeHeader-sc-13pfqk6-13 jzJHyJ bBfEtb dxCWtX"><a href="/js/backbone.localstorage/documentation"><h2 class="PackagePageHeader-sc-ix6jqz-0 gRLNGO">Readme</h2></a><a target="_blank" rel="noopener noreferrer" tabindex="-1" href="/js/backbone.localstorage/documentation" class="packageName__ReadmeHeaderIconWrapper-sc-13pfqk6-14 diUFMs"><svg xmlns="http://www.w3.org/2000/svg" width="12" height="12" viewBox="0 0 9.656 9.656" class="packageName__StyledExpandIcon-sc-13pfqk6-15 kJPcXU"><path fill="currentColor" d="M9.157 9.656H.5a.5.5 0 01-.5-.5V.5A.5.5 0 01.5 0h3.663a.5.5 0 110 1H1v7.658h7.658V5.494a.5.5 0 111 0v3.663a.5.5 0 01-.501.499zm-.832-8.324h-.706L5.475 3.476a.5.5 0 00.706.706l2.144-2.144zm1.332 1.831V.5a.5.5 0 00-.5-.5H6.493a.5.5 0 000 1h2.164v2.164a.5.5 0 101 0z"></path></svg></a></span><div class="Readme__MarkdownContainer-sc-s8l4ky-0 kaPvpf packageName__StyledReadMe-sc-13pfqk6-10 fFiTZA"><div class="markdown-body"><h1 id="backbone-localstorage-backend"><a aria-hidden="true" href="#backbone-localstorage-backend"><span class="icon markdown-icon-link"></span></a>Backbone localStorage Backend</h1>
<p><a href="https://travis-ci.org/jeromegn/Backbone.localStorage" target="_blank" rel="nofollow noopener"><img src="https://travis-ci.org/jeromegn/Backbone.localStorage.svg?branch=master" alt="Build Status"></a>
<a href="https://coveralls.io/github/jeromegn/Backbone.localStorage?branch=master" target="_blank" rel="nofollow noopener"><img src="https://coveralls.io/repos/github/jeromegn/Backbone.localStorage/badge.svg?branch=master" alt="Coverage Status"></a>
<a href="https://badge.fury.io/js/backbone.localstorage" target="_blank" rel="nofollow noopener"><img src="https://badge.fury.io/js/backbone.localstorage.svg" alt="npm version"></a></p>
<p>An adapter that replaces <code>Backbone.sync</code> to save to <code>window.localStorage</code>
instead of to the server.</p>
<p><strong>Note</strong> Backbone LocalStorage v2 changes the API to work more with ES6 modules.
See <a href="#upgrade-notes">Upgrade Notes</a> for more details.</p>
<h2 id="usage"><a aria-hidden="true" href="#usage"><span class="icon markdown-icon-link"></span></a>Usage</h2>
<p>Import <code>backbone.localstorage</code> and attach it to your models and collections:</p>
<pre><code class="hljs language-javascript"><span class="hljs-keyword">import</span> {Collection, Model} <span class="hljs-keyword">from</span> <span class="hljs-string">'backbone'</span>;
<span class="hljs-keyword">import</span> {LocalStorage} <span class="hljs-keyword">from</span> <span class="hljs-string">'backbone.localstorage'</span>;

<span class="hljs-keyword">const</span> SomeCollection = Collection.extend({

  <span class="hljs-attr">localStorage</span>: <span class="hljs-keyword">new</span> LocalStorage(<span class="hljs-string">'SomeCollection'</span>), <span class="hljs-comment">// Uniquely identify this</span>

});

<span class="hljs-keyword">const</span> SomeModel = Model.extend({

  <span class="hljs-attr">localStorage</span>: <span class="hljs-keyword">new</span> LocalStorage(<span class="hljs-string">'SomeModel'</span>)

});
</code></pre>
<p>To synchronise with the server, you can pass the <code>ajaxSync</code> flag to any options:</p>
<pre><code class="hljs language-javascript"><span class="hljs-keyword">const</span> myModel = <span class="hljs-keyword">new</span> SomeModel();
myModel.fetch({
  <span class="hljs-attr">ajaxSync</span>: <span class="hljs-literal">true</span>  <span class="hljs-comment">// Fetches from the server</span>
});

myModel.save({
  <span class="hljs-attr">new</span>: <span class="hljs-string">"value"</span>
}, {
  <span class="hljs-attr">ajaxSync</span>: <span class="hljs-literal">true</span>  <span class="hljs-comment">// Pushes back to the server</span>
});
</code></pre>
<h2 id="upgrade-notes"><a aria-hidden="true" href="#upgrade-notes"><span class="icon markdown-icon-link"></span></a>Upgrade Notes</h2>
<p>Backbone LocalStorage is now built using ES6. It should be fully compatible with
v1 with one difference: Instead of exporting the <code>LocalStorage</code> class as a
default module, v2 exports it as a named variable. Below are examples covering
the changes:</p>
<h3 id="javascript-es5"><a aria-hidden="true" href="#javascript-es5"><span class="icon markdown-icon-link"></span></a>JavaScript ES5</h3>
<p>In v1:</p>
<pre><code class="hljs language-javascript"><span class="hljs-keyword">var</span> LocalStorage = <span class="hljs-built_in">require</span>(<span class="hljs-string">'backbone.localstorage'</span>);
</code></pre>
<p>In v2:</p>
<pre><code class="hljs language-javascript"><span class="hljs-keyword">var</span> localStorage = <span class="hljs-built_in">require</span>(<span class="hljs-string">'backbone.localstorage'</span>);
<span class="hljs-keyword">var</span> LocalStorage = localStorage.LocalStorage;
</code></pre>
<h3 id="javascript-es6"><a aria-hidden="true" href="#javascript-es6"><span class="icon markdown-icon-link"></span></a>JavaScript ES6+</h3>
<p>In v1:</p>
<pre><code class="hljs language-javascript"><span class="hljs-keyword">import</span> LocalStorage <span class="hljs-keyword">from</span> <span class="hljs-string">'backbone.localstorage'</span>;
</code></pre>
<p>In v2:</p>
<pre><code class="hljs language-javascript"><span class="hljs-keyword">import</span> {LocalStorage} <span class="hljs-keyword">from</span> <span class="hljs-string">'backbone.localstorage'</span>;
</code></pre>
<h2 id="contributing"><a aria-hidden="true" href="#contributing"><span class="icon markdown-icon-link"></span></a>Contributing</h2>
<p>Install NodeJS and run <code>yarn</code> or <code>npm i</code> to get your dependencies, then:</p>
<ol>
<li>Open an issue identifying the fault</li>
<li>Provide a fix, with tests demonstrating the issue</li>
<li>Run <code>npm test</code></li>
<li>Create a pull request</li>
</ol>
<h2 id="acknowledgments"><a aria-hidden="true" href="#acknowledgments"><span class="icon markdown-icon-link"></span></a>Acknowledgments</h2>
<ul>
<li><a href="https://github.com/llad" target="_blank" rel="nofollow noopener">Mark Woodall</a>: Initial tests (now refactored)</li>
<li><a href="https://github.com/dwt" target="_blank" rel="nofollow noopener">Martin Häcker</a>: Many fixes and the test isolation</li>
</ul></div></div></div></div><div class="packageName__RightContentContainer-sc-13pfqk6-7 eCPfXh"><div class="packageName__MyStarRatingContainer-sc-13pfqk6-17 htDAkb"><h2 class="PackagePageHeader-sc-ix6jqz-0 packageName__MyStarRatingLabel-sc-13pfqk6-18 gRLNGO DNqeY">Rate &amp; Review</h2><div class="PackageStarRatingInput__Root-sc-17qmcil-0 jmqxOu" tabindex="0"><div class="StarRatingInput__Root-sc-rmq2dw-2 hdrnPp"><div class="StarRatingInput__StarContainer-sc-rmq2dw-0 gjujMW"><svg xmlns="http://www.w3.org/2000/svg" viewBox="-2 -2 34 34" height="32" width="32" class="StarRatingStar__Star-sc-10xew6u-0 hgewxj StarRatingInput__Star-sc-rmq2dw-1 dvInv"><path fill="currentColor" d="M30.342 10.752a1.607 1.607 0 00-1.391-1.084L20.17 8.89 16.7.959a1.633 1.633 0 00-2.975 0L10.253 8.89l-8.783.778a1.612 1.612 0 00-1.391 1.084 1.556 1.556 0 00.472 1.678l6.639 5.682-1.958 8.414a1.559 1.559 0 00.629 1.63 1.646 1.646 0 001.777.077l7.573-4.419 7.571 4.419a1.649 1.649 0 001.779-.077 1.559 1.559 0 00.629-1.63l-1.957-8.414 6.639-5.682a1.556 1.556 0 00.472-1.678zM15.357 23.727" data-name="star icon"></path></svg></div><div class="StarRatingInput__StarContainer-sc-rmq2dw-0 gjujMW"><svg xmlns="http://www.w3.org/2000/svg" viewBox="-2 -2 34 34" height="32" width="32" class="StarRatingStar__Star-sc-10xew6u-0 hgewxj StarRatingInput__Star-sc-rmq2dw-1 dvInv"><path fill="currentColor" d="M30.342 10.752a1.607 1.607 0 00-1.391-1.084L20.17 8.89 16.7.959a1.633 1.633 0 00-2.975 0L10.253 8.89l-8.783.778a1.612 1.612 0 00-1.391 1.084 1.556 1.556 0 00.472 1.678l6.639 5.682-1.958 8.414a1.559 1.559 0 00.629 1.63 1.646 1.646 0 001.777.077l7.573-4.419 7.571 4.419a1.649 1.649 0 001.779-.077 1.559 1.559 0 00.629-1.63l-1.957-8.414 6.639-5.682a1.556 1.556 0 00.472-1.678zM15.357 23.727" data-name="star icon"></path></svg></div><div class="StarRatingInput__StarContainer-sc-rmq2dw-0 gjujMW"><svg xmlns="http://www.w3.org/2000/svg" viewBox="-2 -2 34 34" height="32" width="32" class="StarRatingStar__Star-sc-10xew6u-0 hgewxj StarRatingInput__Star-sc-rmq2dw-1 dvInv"><path fill="currentColor" d="M30.342 10.752a1.607 1.607 0 00-1.391-1.084L20.17 8.89 16.7.959a1.633 1.633 0 00-2.975 0L10.253 8.89l-8.783.778a1.612 1.612 0 00-1.391 1.084 1.556 1.556 0 00.472 1.678l6.639 5.682-1.958 8.414a1.559 1.559 0 00.629 1.63 1.646 1.646 0 001.777.077l7.573-4.419 7.571 4.419a1.649 1.649 0 001.779-.077 1.559 1.559 0 00.629-1.63l-1.957-8.414 6.639-5.682a1.556 1.556 0 00.472-1.678zM15.357 23.727" data-name="star icon"></path></svg></div><div class="StarRatingInput__StarContainer-sc-rmq2dw-0 gjujMW"><svg xmlns="http://www.w3.org/2000/svg" viewBox="-2 -2 34 34" height="32" width="32" class="StarRatingStar__Star-sc-10xew6u-0 hgewxj StarRatingInput__Star-sc-rmq2dw-1 dvInv"><path fill="currentColor" d="M30.342 10.752a1.607 1.607 0 00-1.391-1.084L20.17 8.89 16.7.959a1.633 1.633 0 00-2.975 0L10.253 8.89l-8.783.778a1.612 1.612 0 00-1.391 1.084 1.556 1.556 0 00.472 1.678l6.639 5.682-1.958 8.414a1.559 1.559 0 00.629 1.63 1.646 1.646 0 001.777.077l7.573-4.419 7.571 4.419a1.649 1.649 0 001.779-.077 1.559 1.559 0 00.629-1.63l-1.957-8.414 6.639-5.682a1.556 1.556 0 00.472-1.678zM15.357 23.727" data-name="star icon"></path></svg></div><div class="StarRatingInput__StarContainer-sc-rmq2dw-0 gjujMW"><svg xmlns="http://www.w3.org/2000/svg" viewBox="-2 -2 34 34" height="32" width="32" class="StarRatingStar__Star-sc-10xew6u-0 hgewxj StarRatingInput__Star-sc-rmq2dw-1 dvInv"><path fill="currentColor" d="M30.342 10.752a1.607 1.607 0 00-1.391-1.084L20.17 8.89 16.7.959a1.633 1.633 0 00-2.975 0L10.253 8.89l-8.783.778a1.612 1.612 0 00-1.391 1.084 1.556 1.556 0 00.472 1.678l6.639 5.682-1.958 8.414a1.559 1.559 0 00.629 1.63 1.646 1.646 0 001.777.077l7.573-4.419 7.571 4.419a1.649 1.649 0 001.779-.077 1.559 1.559 0 00.629-1.63l-1.957-8.414 6.639-5.682a1.556 1.556 0 00.472-1.678zM15.357 23.727" data-name="star icon"></path></svg></div></div></div></div><div class="packageName__ReviewInputContainer-sc-13pfqk6-19 fUzuDe" style="height:0px;opacity:0"><div class="PackageQuickFeedback__Root-sc-c61i82-0 bYTRlS" tabindex="0"><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 ilQfnu"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 21.555 24" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.great-documentation-icon_svg__cls-1{fill:#5fef7c}</style></defs><g id="great-documentation-icon_svg__Great_Documentation_Icon" transform="translate(-1210 -569.012)"><path id="great-documentation-icon_svg__Path_22687" d="M226.221 241.141a5.424 5.424 0 105.366 5.423 5.4 5.4 0 00-5.366-5.423zm-.672 8.4l-3.174-3.208 1.145-1.157 2.029 2.051 3.024-3.056 1.145 1.157z" class="great-documentation-icon_svg__cls-1" transform="translate(999.969 341.024)"></path><path id="great-documentation-icon_svg__Path_22688" fill="#07741d" d="M235.285 15v3.818h3.778z" transform="translate(986.317 554.83)"></path><path id="great-documentation-icon_svg__Path_22689" d="M22.983 18.954v-1.636H29.6a7.057 7.057 0 01.776-2.182h-7.393V13.5h8.643a6.922 6.922 0 014.849-1.983V6.273h-6.207V0h-9.983v22.636h10.479a7.067 7.067 0 01-1.264-3.682zm0-9.273h10.793v1.636H22.983z" class="great-documentation-icon_svg__cls-1" transform="translate(1189.715 569.012)"></path></g></svg><span title="Great Documentation" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Great Documentation</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 jkoqpe"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 ilQfnu"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 25.747 25.747" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.easy-to-use-icon_svg__cls-1{fill:#5fef7c}</style></defs><g id="easy-to-use-icon_svg__Easy_to_Use_Icon" transform="translate(-1434.463 -571.781)"><g id="easy-to-use-icon_svg__Group_14070" transform="translate(1434.463 571.781)"><path id="easy-to-use-icon_svg__Path_22703" d="M12.119 3.822V0H2.263A2.265 2.265 0 000 2.263v9.856h4.705a.755.755 0 01.712 1.005 1.509 1.509 0 102.845 0 .755.755 0 01.712-1.005h3.146V9.856a3.017 3.017 0 010-6.034z" class="easy-to-use-icon_svg__cls-1"></path></g><g id="easy-to-use-icon_svg__Group_14072" transform="translate(1445.073 571.781)"><path id="easy-to-use-icon_svg__Path_22704" fill="rgba(17,236,61,0.71)" d="M223.874 0h-9.856v4.705a.755.755 0 01-1.005.712A1.542 1.542 0 00211 6.839a1.545 1.545 0 002.012 1.422.755.755 0 011.005.712v3.146h2.263a3.017 3.017 0 016.035 0h3.822V2.263A2.265 2.265 0 00223.874 0z" transform="translate(-211)"></path></g><g id="easy-to-use-icon_svg__Group_14074" transform="translate(1434.463 585.409)"><path id="easy-to-use-icon_svg__Path_22705" d="M13.125 274.858a.755.755 0 01-1.005-.712V271H9.856a3.017 3.017 0 01-6.034 0H0v9.856a2.265 2.265 0 002.263 2.263h9.856v-4.705a.755.755 0 011.005-.712 1.509 1.509 0 100-2.845z" class="easy-to-use-icon_svg__cls-1" transform="translate(0 -271)"></path></g><g id="easy-to-use-icon_svg__Group_14076" transform="translate(1448.09 582.392)"><path id="easy-to-use-icon_svg__Path_22706" d="M278.414 214.017a.755.755 0 01-.712-1.006 1.509 1.509 0 10-2.845 0 .755.755 0 01-.711 1.006H271v2.263a3.017 3.017 0 010 6.035v3.822h9.856a2.265 2.265 0 002.263-2.263v-9.856z" class="easy-to-use-icon_svg__cls-1" transform="translate(-271 -211)"></path></g></g></svg><span title="Easy to Use" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Easy to Use</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 jkoqpe"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 ilQfnu"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 29.741 19.557" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.performant-icon_svg__cls-1,.performant-icon_svg__cls-2{fill:#5fef7c}.performant-icon_svg__cls-2{opacity:.36}</style></defs><g id="performant-icon_svg__Performant_Icon" transform="translate(-1322.967 -570.443)"><path id="performant-icon_svg__Path_22723" d="M754.185 584.354c0-.065 0-.13-.007-.195s0-.131-.007-.2v-.149l-.006-.082-.026-.328-.006-.083-.01-.107-.02-.214-.021-.213-.011-.106-.013-.1c-.036-.258-.068-.512-.113-.755-.021-.122-.041-.242-.063-.359l-.071-.342c-.044-.222-.1-.43-.145-.622l-.035-.141-.037-.133-.069-.246-.062-.216-.058-.182-.065-.2a.154.154 0 00-.189-.1l-5.028 1.433a.154.154 0 00-.109.177l.019.1.024.125.023.148.026.169c0 .03.01.06.014.091l.011.1c.014.131.035.271.044.422l.019.23c0 .079.007.16.011.241.011.163.009.333.012.5v.485l-.014.328v.093l-.012.128-.011.127-.015.125c-.011.083-.017.165-.03.245l-.034.236-.039.224c-.012.073-.027.143-.04.211l-.04.2-.041.179-.019.082-.018.066-.01.038h6.15a.154.154 0 00.154-.147l.016-.352c.006-.12 0-.243.007-.368s0-.251 0-.379c-.035-.055-.035-.119-.036-.184z" class="performant-icon_svg__cls-1" transform="translate(598.519 4.205)"></path><path id="performant-icon_svg__Path_22724" d="M658.607 337.621a.154.154 0 00.082-.209l-.059-.125-.07-.147-.106-.216-.122-.245c-.022-.045-.043-.082-.065-.124l-.069-.126-.146-.268-.164-.282-.086-.147-.092-.148-.191-.3c-.137-.2-.273-.413-.426-.619l-.113-.156-.057-.078-.059-.077-.237-.307-.246-.3c-.041-.05-.081-.1-.123-.148l-.126-.144-.126-.142a4.154 4.154 0 00-.126-.139l-.252-.269c-.083-.088-.169-.171-.25-.253s-.162-.163-.244-.238l-.235-.22c-.076-.071-.153-.136-.225-.2l-.209-.182-.193-.159-.17-.139c-.052-.043-.1-.08-.147-.114l-.162-.124a.154.154 0 00-.213.024l-2.7 3.267a.154.154 0 00.01.208l.078.077c.028.028.06.058.093.093l.107.113.122.128.13.146c.044.051.093.1.14.159l.145.174c.051.059.1.123.149.187s.1.129.153.2l.152.208c.026.035.051.071.075.108l.075.11.075.11c.025.037.048.076.072.113.048.076.1.151.144.228l.137.232.034.058.032.059.064.117c.088.153.161.311.239.459l.1.224.051.108.046.107.088.2.076.194.036.091c.011.029.025.06.032.085l.049.144.044.126.049.147.044.131a.154.154 0 00.2.094z" class="performant-icon_svg__cls-1" transform="translate(692.497 244.483)"></path><path id="performant-icon_svg__Path_22725" d="M452.043 238.4l.135.018.159.028.18.031c.055.009.112.022.171.035l1.7-3.484-.25-.039c-.056-.008-.112-.018-.167-.025l-.163-.02-.313-.037-.293-.025c-.094-.007-.183-.017-.269-.021l-.243-.012-.213-.01h-.376a.154.154 0 00-.156.147l-.155 3.243a.154.154 0 00.133.16z" class="performant-icon_svg__cls-2" transform="translate(885.319 337.865)"></path><path id="performant-icon_svg__Path_22726" d="M596.235 270.467l.13.095.115.082.061.045.061.045.111.082a.154.154 0 00.221-.039l2.224-3.387a.154.154 0 00-.052-.219l-.12-.069-.066-.038-.079-.044-.2-.113-.233-.127-.246-.123c-.086-.042-.174-.089-.268-.131l-.29-.133c-.1-.047-.2-.089-.309-.134s-.214-.091-.325-.133l-.086-.032-.959 4.164c.053.033.1.069.152.1z" class="performant-icon_svg__cls-2" transform="translate(745.704 307.588)"></path><path id="performant-icon_svg__Path_22727" fill="#5fef7c" d="M190.128 241.258c.043-.006.085-.013.127-.017l.125-.013.238-.025.224-.015.1-.007c.034 0 .068-.005.1-.005h.622a.154.154 0 00.153-.164l-.2-3.055a.154.154 0 00-.173-.143l-.137.017-.159.02-.222.033-.252.038c-.045.006-.087.015-.131.023l-.134.026-.284.055-.3.069-.157.036c-.053.012-.106.028-.16.041l-.329.088-.337.1c-.057.018-.114.034-.171.053l-.171.058-.172.059c-.058.02-.115.039-.172.062l-.343.131c-.114.045-.226.094-.339.141l-.168.071-.164.076-.163.075c-.054.025-.108.05-.16.077l-.311.157c-.1.051-.2.108-.3.159s-.191.1-.28.158l-.261.155c-.085.049-.163.1-.24.151l-.219.141-.193.133-.17.117-.141.1-.147.109a.154.154 0 00-.036.211l1.268 1.865a.154.154 0 00.2.048l.114-.064c.038-.021.079-.046.125-.07l.15-.078.17-.089.191-.092c.067-.031.135-.067.208-.1l.225-.1c.076-.035.157-.066.239-.1s.165-.068.251-.1l.262-.095c.044-.017.089-.031.134-.045l.136-.044.137-.044.139-.04c.093-.026.186-.054.28-.078l.282-.07c.046-.012.094-.022.141-.032l.14-.03.139-.029.138-.025.271-.047z" opacity="0.29" transform="translate(1144.249 334.994)"></path><path id="performant-icon_svg__Path_22728" fill="#5fef7c" d="M25.4 360.286l-.1.142-.1.143c-.034.048-.065.1-.1.146-.064.1-.13.2-.193.295l-.184.3-.046.075-.043.076-.086.151c-.117.2-.219.4-.322.6l-.142.29-.068.14-.063.139-.119.266-.1.252c-.033.081-.066.158-.094.232l-.079.211-.069.186-.054.159-.055.162a.154.154 0 00.091.193l1.181.453a.154.154 0 00.194-.077l.061-.128.065-.135.081-.157.092-.178c.033-.062.07-.126.108-.194l.118-.21.133-.22.069-.115.075-.115.154-.238c.111-.157.22-.323.342-.482l.09-.121.045-.061.047-.06.19-.239c.065-.079.131-.156.2-.233.033-.038.065-.078.1-.115l.1-.111.1-.111c.033-.037.066-.073.1-.108l.2-.208c.066-.068.134-.131.2-.2s.128-.126.194-.183l.186-.17c.06-.055.121-.1.178-.154l.164-.14.145-.115.127-.1a1.15 1.15 0 01.063-.048l.061-.046.11-.083a.154.154 0 00.024-.223l-1.344-1.575a.154.154 0 00-.224-.011l-.1.1-.055.053-.062.061-.149.151-.169.171-.174.188c-.06.066-.124.133-.187.206l-.194.225c-.067.076-.133.158-.2.242s-.137.167-.2.256l-.2.269a.518.518 0 00-.113.131z" opacity="0.2" transform="translate(1300.329 218.377)"></path><path id="performant-icon_svg__Path_22729" fill="#5fef7c" d="M.318 597.752l-.027.135-.032.156-.035.2-.039.225-.02.121-.017.125c-.022.171-.051.354-.068.551l-.03.3c-.008.1-.014.208-.021.315-.017.213-.02.434-.027.658v.678l.014.339v.172l.012.162.012.161.016.166.016.164.008.081.01.079.039.309.045.295c.014.1.032.188.048.278v.021a.154.154 0 00.152.126h.434a.154.154 0 00.154-.163v-.072c-.005-.086-.011-.175-.013-.267l-.009-.282v-.747l.008-.161.008-.162v-.064c0-.006 0 .006 0 0v-.015l.006-.079.025-.317.013-.077.009-.079.018-.157.018-.157.009-.078.012-.077c.032-.206.059-.408.1-.6.019-.1.035-.192.054-.285l.061-.271c.036-.177.084-.341.122-.493l.029-.112c.01-.036.021-.07.031-.1l.057-.19c.018-.06.033-.114.051-.168l.05-.151.043-.131a.154.154 0 00-.107-.2l-1.043-.278a.154.154 0 00-.196.116z" opacity="0.06" transform="translate(1322.967 -13.568)"></path><path id="performant-icon_svg__Path_22730" d="M345.64 181.808a2.4 2.4 0 003.211-1.1 2.519 2.519 0 00.183-.516l2.429-10.541.925-4.014.573-2.487a.394.394 0 00-.395-.487.378.378 0 00-.347.224l-1.166 2.385-1.72 3.518-4.8 9.808a2.4 2.4 0 001.107 3.21zm1.142-3.395a1.177 1.177 0 11-1.177 1.177 1.177 1.177 0 011.177-1.177z" class="performant-icon_svg__cls-1" transform="translate(989.452 407.782)"></path></g></svg><span title="Performant" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Performant</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 jkoqpe"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 ilQfnu"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 21.002 21" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.highly-customizable-icon_svg__cls-1{fill:#5fef7c}.highly-customizable-icon_svg__cls-2{fill:#4ed168}</style></defs><g id="highly-customizable-icon_svg__Highly_Customizable_Icon" transform="translate(-1548.257 -569.559)"><path id="highly-customizable-icon_svg__Path_22710" d="M218.051 2.335C217.9 5.176 213 9.8 209.363 12.842l-.3-.014-3.563-3.561-.019-.305c2.893-3.713 7.272-8.65 10.1-8.947a2.161 2.161 0 012.471 2.32z" class="highly-customizable-icon_svg__cls-1" transform="translate(1351.205 569.559)"></path><path id="highly-customizable-icon_svg__Path_22711" d="M259.931 20.122c-.152 2.841-5.048 7.47-8.688 10.507l-.3-.014-1.788-1.788 10.278-10.279a2.231 2.231 0 01.498 1.574z" class="highly-customizable-icon_svg__cls-2" transform="translate(1309.323 551.771)"></path><path id="highly-customizable-icon_svg__Path_22712" fill="#17b742" d="M157.5 222.374a79.714 79.714 0 01-2.87 2.286 3.779 3.779 0 00-3.229-3.175c.027-.041.923-1.331 2.218-2.99z" opacity="0.612" transform="translate(1403.067 360.027)"></path><path id="highly-customizable-icon_svg__Path_22713" fill="#20604a" d="M206.458 267.585a79.759 79.759 0 01-2.87 2.285 3.868 3.868 0 00-1.135-2.173l2.059-2.059z" opacity="0.129" transform="translate(1354.108 314.815)"></path><path id="highly-customizable-icon_svg__Path_22714" d="M8.482 286.728a4.328 4.328 0 00-6.331.565c-1.793 2.241-.292 4.241-1.983 6.024a.616.616 0 00.2.989A7.614 7.614 0 008.335 293a4.493 4.493 0 00.147-6.272z" class="highly-customizable-icon_svg__cls-1" transform="translate(1548.258 295.675)"></path><path id="highly-customizable-icon_svg__Path_22715" d="M24.81 318.631a7.6 7.6 0 01-7.631 1.434l7.743-7.744a4.483 4.483 0 01-.112 6.31z" class="highly-customizable-icon_svg__cls-2" transform="translate(1531.784 270.047)"></path></g></svg><span title="Highly Customizable" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Highly Customizable</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 jkoqpe"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 ilQfnu"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 18.995 26.399" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><path fill="#5fef7c" d="M6.99 0L.001 13.982h7.122L3.572 25.966l.805.433L18.996 8.856h-8.932L16.594 0H6.99z"></path></svg><span title="Bleeding Edge" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Bleeding Edge</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 jkoqpe"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 ilQfnu"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 26.949 28.001" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.responsive-maintainers-icon_svg__cls-1{fill:#11ec3d}.responsive-maintainers-icon_svg__cls-2{fill:#16b741}.responsive-maintainers-icon_svg__cls-6{fill:#25364e}</style></defs><g id="responsive-maintainers-icon_svg__Responsive_Maintainers_Icon" transform="translate(-1777.027 -569.559)"><path id="responsive-maintainers-icon_svg__Path_22695" d="M291.512 64.249v7.943h3.146l-.026 1.924 3.451-1.924h3.909v-7.943z" class="responsive-maintainers-icon_svg__cls-1" transform="translate(1500.858 508.823)"></path><path id="responsive-maintainers-icon_svg__Path_22696" d="M391.067 64.249v8.686l1.331-.743h3.909v-7.943z" class="responsive-maintainers-icon_svg__cls-2" transform="translate(1406.544 508.823)"></path><path id="responsive-maintainers-icon_svg__Path_22697" d="M33.8 0H21.38v9.317h4.632L30 11.539l-.03-2.222h3.83z" class="responsive-maintainers-icon_svg__cls-1" transform="translate(1756.774 569.559)"></path><path id="responsive-maintainers-icon_svg__Path_22698" d="M145.575 0h-6.21v10.2l2.405 1.341-.03-2.222h3.835z" class="responsive-maintainers-icon_svg__cls-2" transform="translate(1644.998 569.559)"></path><path id="responsive-maintainers-icon_svg__Path_22699" fill="#1da040" d="M8.386 264.617a4.253 4.253 0 001.578-3.326 4.128 4.128 0 00-4.043-4.2 4.128 4.128 0 00-4.043 4.2 4.253 4.253 0 001.578 3.326A6.178 6.178 0 000 270.211v.82h11.843v-.82a6.178 6.178 0 00-3.457-5.594z" transform="translate(1777.027 326.527)"></path><path id="responsive-maintainers-icon_svg__Path_22700" fill="#3cb454" d="M295.386 264.618a4.254 4.254 0 001.578-3.326 4.046 4.046 0 10-8.085 0 4.253 4.253 0 001.578 3.326 6.178 6.178 0 00-3.457 5.594v.82h11.843v-.82a6.178 6.178 0 00-3.457-5.594z" transform="translate(1505.133 326.527)"></path><path id="responsive-maintainers-icon_svg__Path_22701" fill="#5fef7c" d="M140.076 235.623a4.671 4.671 0 001.967-3.835 4.452 4.452 0 10-8.9 0 4.671 4.671 0 001.967 3.835 6.85 6.85 0 00-4.1 6.33v.791h13.157v-.791a6.85 6.85 0 00-4.091-6.33z" transform="translate(1652.907 354.816)"></path><path id="responsive-maintainers-icon_svg__Rectangle_1208" d="M0 0h5.163v1.641H0z" class="responsive-maintainers-icon_svg__cls-6" transform="translate(1781.781 573.313)"></path><path id="responsive-maintainers-icon_svg__Rectangle_1209" d="M0 0h4.239v1.641H0z" class="responsive-maintainers-icon_svg__cls-6" transform="translate(1795.492 576.155)"></path><path id="responsive-maintainers-icon_svg__Path_22702" fill="#4ed168" d="M258.481 235.623a4.671 4.671 0 001.967-3.835 4.543 4.543 0 00-4.448-4.622v15.577h6.579v-.791a6.85 6.85 0 00-4.098-6.329z" transform="translate(1534.502 354.816)"></path><path id="responsive-maintainers-icon_svg__Rectangle_1210" d="M0 0h2.581v1.641H0z" class="responsive-maintainers-icon_svg__cls-6" transform="translate(1784.364 573.313)"></path><path id="responsive-maintainers-icon_svg__Rectangle_1211" d="M0 0h2.119v1.641H0z" class="responsive-maintainers-icon_svg__cls-6" transform="translate(1797.613 576.155)"></path></g></svg><span title="Responsive Maintainers" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Responsive Maintainers</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 jkoqpe"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 hARnEk"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 21.616 23.809" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.poor-documentation-icon_svg__cls-1{fill:#de5e78}</style></defs><g id="poor-documentation-icon_svg__Poor_Documentation_Icon" transform="translate(-1210.682 -637.23)"><path id="poor-documentation-icon_svg__Path_22687" d="M226.236 241.141a5.38 5.38 0 105.381 5.38 5.387 5.387 0 00-5.381-5.38z" class="poor-documentation-icon_svg__cls-1" transform="translate(1000.681 409.138)"></path><path id="poor-documentation-icon_svg__Path_22688" fill="#ba3b54" d="M235.285 15v3.788h3.788z" transform="translate(987.032 623.042)"></path><path id="poor-documentation-icon_svg__Path_22689" d="M22.991 18.8v-1.619h6.636a6.953 6.953 0 01.778-2.165h-7.414v-1.623h8.666a6.98 6.98 0 014.862-1.968v-5.2H30.3V0H20.285v22.457h10.508a6.963 6.963 0 01-1.268-3.657zm0-9.2h10.822v1.623H22.991z" class="poor-documentation-icon_svg__cls-1" transform="translate(1190.396 637.23)"></path><path id="poor-documentation-icon_svg__Path_22755" fill="none" stroke="#0b121e" d="M-6672.671 244.132l-3.183 3.181 3.183-3.181-3.183-3.181 3.183 3.181 3.183-3.181-3.183 3.181 3.183 3.181z" transform="translate(7899.617 411.517)"></path></g></svg><span title="Poor Documentation" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Poor Documentation</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 ibXUYO"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 hARnEk"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 28 28" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.hard-to-use-icon_svg__cls-2{fill:#ba3b54}</style></defs><g id="hard-to-use-icon_svg__Hard_to_Use_Icon" transform="translate(-1432.83 -637.83)"><circle id="hard-to-use-icon_svg__Ellipse_563" cx="14" cy="14" r="14" fill="#de5e78" transform="translate(1432.83 637.83)"></circle><path id="hard-to-use-icon_svg__Path_22752" d="M20.529 18.841a8.583 8.583 0 00-8.022-6.164 8.583 8.583 0 00-8.022 6.164.935.935 0 00.1.789.785.785 0 00.655.37h14.533a.785.785 0 00.653-.366.935.935 0 00.103-.793z" class="hard-to-use-icon_svg__cls-2" transform="translate(1434.575 639.633)"></path><path id="hard-to-use-icon_svg__Path_22753" d="M6.868 11.788a.868.868 0 01-.466-1.6l2.032-1.294L6.4 7.6a.869.869 0 01.933-1.465l3.183 2.026a.869.869 0 010 1.465l-3.181 2.026a.869.869 0 01-.466.135z" class="hard-to-use-icon_svg__cls-2" transform="translate(1434.136 639.142)"></path><path id="hard-to-use-icon_svg__Path_22754" d="M17.8 11.788a.868.868 0 01-.465-.135l-3.182-2.026a.868.868 0 010-1.465l3.183-2.026a.869.869 0 11.932 1.464l-2.033 1.294 2.033 1.293a.868.868 0 01-.466 1.6z" class="hard-to-use-icon_svg__cls-2" transform="translate(1435.356 639.142)"></path></g></svg><span title="Hard to Use" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Hard to Use</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 ibXUYO"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 hARnEk"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 31.425 22.187" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.slow-icon_svg__cls-1{fill:#ff5774}.slow-icon_svg__cls-3{fill:#ff5e7a}</style></defs><g id="slow-icon_svg__Slow_Icon" transform="translate(-1320 -638.93)"><path id="slow-icon_svg__Path_22772" d="M4.711 18.427a.5.5 0 01-.429-.244L.044 10.964a.5.5 0 11.858-.5l4.238 7.219a.5.5 0 01-.429.753z" class="slow-icon_svg__cls-1" transform="translate(1320.051 629.219)"></path><path id="slow-icon_svg__Path_22773" d="M9.065 17.514a.5.5 0 01-.5-.459L8 9.787a.5.5 0 011-.08l.568 7.269a.5.5 0 01-.459.538z" class="slow-icon_svg__cls-1" transform="translate(1316.016 629.683)"></path><path id="slow-icon_svg__Path_22774" fill="#de5e78" d="M8.478 36.425a2.855 2.855 0 002.348 1.78H30.52l-2.6-2.368-15.952-4.861L6.983 24a3.144 3.144 0 00-2.992-1.25C2.406 22.75 1 23.657 1 25.243s2.029 2.867 3.615 2.867z" transform="translate(1319.524 622.912)"></path><circle id="slow-icon_svg__Ellipse_565" cx="10.215" cy="10.215" r="10.215" class="slow-icon_svg__cls-3" transform="translate(1330.994 640.427)"></circle><circle id="slow-icon_svg__Ellipse_566" cx="5.983" cy="5.983" r="5.983" fill="#ba3b54" transform="translate(1336.976 644.789)"></circle><circle id="slow-icon_svg__Ellipse_567" cx="2.059" cy="2.059" r="2.059" class="slow-icon_svg__cls-3" transform="translate(1341.837 648.902)"></circle></g></svg><span title="Slow" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Slow</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 ibXUYO"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 hARnEk"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 25.518 25.512" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.buggy-icon_svg__cls-1{fill:#de5e78}</style></defs><g id="buggy-icon_svg__Buggy_Icon" transform="translate(-1548.395 -638.008)"><path id="buggy-icon_svg__Path_22740" d="M242.438 4.652h-1.495a.747.747 0 010-1.495h1.495a.748.748 0 00.747-.747V.81a.748.748 0 011.495 0v1.6a2.245 2.245 0 01-2.242 2.242z" class="buggy-icon_svg__cls-1" transform="translate(1320.166 637.938)"></path><path id="buggy-icon_svg__Path_22741" d="M183.816 4.652h-1.495a2.245 2.245 0 01-2.242-2.242V.81a.747.747 0 011.495 0v1.6a.748.748 0 00.747.747h1.495a.747.747 0 010 1.495z" class="buggy-icon_svg__cls-1" transform="translate(1377.291 637.938)"></path><path id="buggy-icon_svg__Path_22742" d="M6.988 303.451h-5.98a.747.747 0 010-1.495h5.98a.747.747 0 010 1.495z" class="buggy-icon_svg__cls-1" transform="translate(1548.14 351.099)"></path><path id="buggy-icon_svg__Path_22743" d="M155.32 62.021a5.238 5.238 0 00-5.232 5.232.74.74 0 00.747.747h8.965a.74.74 0 00.747-.747 5.238 5.238 0 00-5.227-5.232z" class="buggy-icon_svg__cls-1" transform="translate(1405.786 579.075)"></path><path id="buggy-icon_svg__Path_22744" d="M6.745 128.015h-2.33a3.732 3.732 0 01-3.545-2.556l-.813-2.44a.747.747 0 011.418-.473l.813 2.44a2.241 2.241 0 002.128 1.534h2.33a.747.747 0 01-.001 1.495z" class="buggy-icon_svg__cls-1" transform="translate(1548.383 522.051)"></path><path id="buggy-icon_svg__Path_22745" d="M.045 396.926l.813-2.44A3.732 3.732 0 014.4 391.93h2.33a.747.747 0 010 1.495H4.4a2.241 2.241 0 00-2.128 1.534l-.813 2.44a.747.747 0 01-1.414-.473z" class="buggy-icon_svg__cls-1" transform="translate(1548.395 265.609)"></path><path id="buggy-icon_svg__Path_22746" d="M366.807 303.641h-6.1a.742.742 0 010-1.485h6.1a.742.742 0 010 1.485z" class="buggy-icon_svg__cls-1" transform="translate(1206.365 350.909)"></path><path id="buggy-icon_svg__Path_22747" d="M363.127 128.814h-2.417a.742.742 0 010-1.485h2.417a2.262 2.262 0 002.138-1.544l.813-2.44a.747.747 0 011.417.473l-.813 2.44a3.745 3.745 0 01-3.555 2.556z" class="buggy-icon_svg__cls-1" transform="translate(1206.365 521.29)"></path><path id="buggy-icon_svg__Path_22748" d="M366.079 397.4l-.813-2.44a2.241 2.241 0 00-2.128-1.534h-2.427a.747.747 0 010-1.495h2.417a3.745 3.745 0 013.555 2.556l.813 2.44a.747.747 0 01-1.417.473z" class="buggy-icon_svg__cls-1" transform="translate(1206.365 265.608)"></path><path id="buggy-icon_svg__Path_22749" d="M260.29 67.253a.74.74 0 01-.747.747h-4.485v-5.98a5.238 5.238 0 015.232 5.233z" class="buggy-icon_svg__cls-1" transform="translate(1306.048 579.075)"></path><path id="buggy-icon_svg__Path_22750" d="M131.307 152h-8.969a2.239 2.239 0 00-2.242 2.242v8.969a6.722 6.722 0 1013.444 0v-8.969a2.231 2.231 0 00-2.233-2.242z" class="buggy-icon_svg__cls-1" transform="translate(1434.286 493.584)"></path><path id="buggy-icon_svg__Path_22751" fill="#ba3b54" d="M261.776 154.238v8.969a6.729 6.729 0 01-6.717 6.727V152h4.485a2.231 2.231 0 012.232 2.238z" transform="translate(1306.048 493.584)"></path></g></svg><span title="Buggy" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Buggy</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 ibXUYO"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 hARnEk"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 28.252 28.252" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.abandoned-icon_svg__cls-1{fill:#de5e78}</style></defs><g id="abandoned-icon_svg__Abandoned_Icon" transform="translate(-1663.393 -638.213)"><path id="abandoned-icon_svg__Path_22759" d="M18.265 369.449a.82.82 0 01-.828.828H.828a.82.82 0 01-.828-.828 4.923 4.923 0 015.314-4.95A4.235 4.235 0 019.16 362a4.156 4.156 0 013.791 2.5 4.932 4.932 0 015.314 4.949z" class="abandoned-icon_svg__cls-1" transform="translate(1663.393 296.188)"></path><path id="abandoned-icon_svg__Path_22760" d="M175.1 369.449a.82.82 0 01-.828.828H166V362a4.156 4.156 0 013.791 2.5 4.932 4.932 0 015.309 4.949z" class="abandoned-icon_svg__cls-1" transform="translate(1506.554 296.188)"></path><path id="abandoned-icon_svg__Path_22761" d="M4.139 0a4.139 4.139 0 000 8.277 4.187 4.187 0 004.193-4.138A4.187 4.187 0 004.139 0z" class="abandoned-icon_svg__cls-1" transform="translate(1663.393 638.213)"></path><path id="abandoned-icon_svg__Path_22762" d="M220.932 61.655v23.286h-3.311V73.354A6.6 6.6 0 01211 66.732v-3.421a1.655 1.655 0 113.311 0v3.421a3.342 3.342 0 003.311 3.311v-8.388a1.655 1.655 0 013.311 0z" class="abandoned-icon_svg__cls-1" transform="translate(1464.036 581.524)"></path><path id="abandoned-icon_svg__Path_22763" d="M376.828 190.277l-.828.46v2.4l.828.448a6.645 6.645 0 006.677-6.622v-3.311a1.655 1.655 0 10-3.311 0v3.311a3.379 3.379 0 01-3.366 3.314z" class="abandoned-icon_svg__cls-1" transform="translate(1308.14 466.256)"></path><path id="abandoned-icon_svg__Path_22764" fill="#ba3b54" d="M362.655 61.655v23.286H361V60a1.66 1.66 0 011.655 1.655z" transform="translate(1322.312 581.524)"></path><path id="abandoned-icon_svg__Path_22765" d="M28.252 482.828a.82.82 0 01-.828.828H.828a.828.828 0 110-1.655h26.6a.82.82 0 01.824.827z" class="abandoned-icon_svg__cls-1" transform="translate(1663.393 182.809)"></path><path id="abandoned-icon_svg__Path_22766" d="M369.332 482.828a.82.82 0 01-.828.828H361V482h7.5a.82.82 0 01.832.828z" class="abandoned-icon_svg__cls-1" transform="translate(1322.312 182.809)"></path><path id="abandoned-icon_svg__Path_22767" d="M79.194 4.139A4.187 4.187 0 0175 8.277V0a4.187 4.187 0 014.194 4.139z" class="abandoned-icon_svg__cls-1" transform="translate(1592.531 638.213)"></path></g></svg><span title="Abandoned" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Abandoned</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 ibXUYO"></div></div><div class="PackageQuickFeedbackTile__Root-sc-1i38i1h-0 hARnEk"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 20.421 25.945" class="PackageBadgeIcon__Root-sc-1e0ug4w-0 jCLlqi PackageQuickFeedbackTile__StyledIcon-sc-1i38i1h-1 llqcLZ"><defs><style>.unwelcoming-community-icon_svg__cls-1{fill:#de5e78}</style></defs><g id="unwelcoming-community-icon_svg__Unwelcoming_Community_Icon" transform="translate(-1777.164 -637.584)"><circle id="unwelcoming-community-icon_svg__Ellipse_568" cx="1.497" cy="1.497" r="1.497" class="unwelcoming-community-icon_svg__cls-1" transform="translate(1794.591 641.576)"></circle><circle id="unwelcoming-community-icon_svg__Ellipse_569" cx="1.497" cy="1.497" r="1.497" class="unwelcoming-community-icon_svg__cls-1" transform="translate(1790.599 638.582)"></circle><circle id="unwelcoming-community-icon_svg__Ellipse_570" cx="1.497" cy="1.497" r="1.497" class="unwelcoming-community-icon_svg__cls-1" transform="translate(1786.608 637.584)"></circle><circle id="unwelcoming-community-icon_svg__Ellipse_571" cx="1.497" cy="1.497" r="1.497" class="unwelcoming-community-icon_svg__cls-1" transform="translate(1782.618 639.58)"></circle><path id="unwelcoming-community-icon_svg__Path_22778" d="M20.195 5.491v6.486a.5.5 0 11-1 0V2.5H16.2v8.48a.5.5 0 11-1 0V1.5h-2.988v9.48a.5.5 0 11-1 0V3.5H8.22v12.469L6.2 13.2a1.948 1.948 0 00-2.623-.7 1.89 1.89 0 00-.474 2.64s3.259 4.932 4.648 7.044 3.639 3.763 7.847 3.763c6.967 0 7.591-5.381 7.591-6.985V5.491z" class="unwelcoming-community-icon_svg__cls-1" transform="translate(1774.396 637.581)"></path></g></svg><span title="Unwelcoming Community" class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__Label-sc-1i38i1h-2 jzJHyJ geAIss">Unwelcoming Community</span><span class="Typography-sc-ye08y9-0 PackageQuickFeedbackTile__VoteCount-sc-1i38i1h-3 jzJHyJ habypx">0</span><div class="PackageQuickFeedbackTile__Fade-sc-1i38i1h-4 ibXUYO"></div></div></div><form class="ReviewPageTextReviewInput__Root-sc-1l5uctd-0 kODeLN packageName__PackageReviewInput-sc-13pfqk6-27 xMwpI" tabindex="0"><div class="ReviewPageTextReviewInput__InputContainer-sc-1l5uctd-1 jnNgsb"><div class="ReviewPageTextReviewInput__InputTop-sc-1l5uctd-2 dpVLQO"><svg xmlns="http://www.w3.org/2000/svg" width="28" height="28" viewBox="0 0 28.056 28.056" class="ReviewPageTextReviewInput__CurrentUserAvatar-sc-1l5uctd-4 iQMuKp"><path fill="currentColor" d="M14.028 0a14.028 14.028 0 1014.028 14.028A14.044 14.044 0 0014.028 0zm0 4.091a6.722 6.722 0 11-6.722 6.722 6.73 6.73 0 016.722-6.722zm0 21.626a11.667 11.667 0 01-9.341-4.691 22.011 22.011 0 019.341-2.326 22.012 22.012 0 019.341 2.322 11.667 11.667 0 01-9.341 4.696z"></path></svg><textarea name="text" placeholder="Write a review for this package!

For example: I’ve used this library both professionally and in my side projects.
It’s easy to use, however it’s a bit lacking in terms of customizability, and I would appreciate a more flexible API.
One killer feature is the built-in responsive design, and in addition, this library also has several plugins available.
In comparison to space-slider, I found this library to be more performant and less buggy, so I have switched and I’m not looking back..." rows="1" class="ReviewPageTextReviewInput__TextArea-sc-1l5uctd-5 fXVxSu"></textarea></div><div class="ReviewPageTextReviewInput__ProgressContainer-sc-1l5uctd-3 himbRG"><div class="ProgressCircle__Container-sc-zu1l7n-0 fFgiaQ ReviewPageTextReviewInput__RemainingProgress-sc-1l5uctd-6 danmuH" size="28"><svg width="28" height="28" stroke-width="10.00" viewBox="0.00 0.00 100.00 100.00" class="ProgressCircle__Svg-sc-zu1l7n-1 fzbrwc"><path d="M 50,50 m 0,-45 a 45,45 0 1 1 0,90 a 45,45 0 1 1 0,-90" class="ProgressCircle__Path-sc-zu1l7n-2 ProgressCircle__PathTrack-sc-zu1l7n-3 jwEJsg boDPfz"></path><path d="M 50,50 m 0,-45 a 45,45 0 1 1 0,90 a 45,45 0 1 1 0,-90" pathLength="280" stroke-dasharray="280 280" stroke-dashoffset="280" class="ProgressCircle__Path-sc-zu1l7n-2 ProgressCircle__PathHead-sc-zu1l7n-4 jwEJsg hqvIPQ"></path></svg><span class="Typography-sc-ye08y9-0 ProgressCircle__Text-sc-zu1l7n-5 jzJHyJ cMrnsR">100</span></div></div></div><div class="ReviewPageTextReviewInput__ButtonContainer-sc-1l5uctd-7 bDUyVV"><button disabled="" type="submit" class="Button-sc-xkagug-0 ReviewPageTextReviewInput__SubmitButton-sc-1l5uctd-10 bQhDjQ kWAEKz"><span>Publish</span><svg xmlns="http://www.w3.org/2000/svg" width="14" height="14" viewBox="0 0 14.434 14.251" class="ReviewPageTextReviewInput__SubmitIcon-sc-1l5uctd-11 jHbVlN"><path fill="currentColor" d="M5.636 10.592v3.15a.509.509 0 00.92.3l1.843-2.508zM14.244.084a.451.451 0 00-.47-.032L.242 7.118a.451.451 0 00.058.826L4.067 9.23l8.011-6.85-6.2 7.469L12.183 12a.461.461 0 00.146.024.451.451 0 00.446-.384L14.429.518a.452.452 0 00-.185-.434z"></path></svg></button></div></form></div><div class="ZeroStateOverlay__Root-sc-1nln770-0 fjUKd"><div class="ZeroStateOverlay__Body-sc-1nln770-1 xXuGK"><div style="display:inline-block;max-width:100%;overflow:hidden;position:relative;box-sizing:border-box;margin:0"><div style="box-sizing:border-box;display:block;max-width:100%"><img style="max-width:100%;display:block;margin:0;border:none;padding:0" alt="" aria-hidden="true" role="presentation" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTA4NiIgaGVpZ2h0PSIxMTM4IiB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZlcnNpb249IjEuMSIvPg=="/></div><noscript><img srcSet="/_next/image?url=%2Fpngs%2FsampleReviews.png&amp;w=1200&amp;q=75 1x, /_next/image?url=%2Fpngs%2FsampleReviews.png&amp;w=3840&amp;q=75 2x" src="/_next/image?url=%2Fpngs%2FsampleReviews.png&amp;w=3840&amp;q=75" decoding="async" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" decoding="async" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/></div></div><div class="ZeroStateOverlay__Overlay-sc-1nln770-2 hSSRbD"><div class="ZeroStateOverlay__Label-sc-1nln770-3 jJfMsy">No reviews found</div><a type="button" class="Pill__Root-sc-1t99j9w-0 dQDFEV ZeroStateOverlay__StyledPill-sc-1nln770-4 kABRub">Be the first to rate</a></div></div><div class="packageName__TutorialsContainer-sc-13pfqk6-22 packageName__AlternativesContainer-sc-13pfqk6-26 cbmAHA jpeaCf"><span class="Typography-sc-ye08y9-0 packageName__StyledPackagePageHeader-sc-13pfqk6-2 packageName__TutorialsHeader-sc-13pfqk6-23 packageName__AlternativesHeader-sc-13pfqk6-24 jzJHyJ bBfEtb hionN"><a href="/js/backbone.localstorage/alternatives"><h2 class="PackagePageHeader-sc-ix6jqz-0 gRLNGO">Alternatives</h2></a></span><div class="ZeroStateOverlay__Root-sc-1nln770-0 fjUKd"><div class="ZeroStateOverlay__Body-sc-1nln770-1 xXuGK"><div style="display:inline-block;max-width:100%;overflow:hidden;position:relative;box-sizing:border-box;margin:0"><div style="box-sizing:border-box;display:block;max-width:100%"><img style="max-width:100%;display:block;margin:0;border:none;padding:0" alt="" aria-hidden="true" role="presentation" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTA5MiIgaGVpZ2h0PSIxMTE4IiB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZlcnNpb249IjEuMSIvPg=="/></div><noscript><img srcSet="/_next/image?url=%2Fpngs%2FsampleAlternatives.png&amp;w=1200&amp;q=75 1x, /_next/image?url=%2Fpngs%2FsampleAlternatives.png&amp;w=3840&amp;q=75 2x" src="/_next/image?url=%2Fpngs%2FsampleAlternatives.png&amp;w=3840&amp;q=75" decoding="async" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" decoding="async" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/></div></div><div class="ZeroStateOverlay__Overlay-sc-1nln770-2 hSSRbD"><div class="ZeroStateOverlay__Label-sc-1nln770-3 jJfMsy">No alternatives found</div><button type="button" class="Pill__Root-sc-1t99j9w-0 dQDFEV ZeroStateOverlay__StyledPill-sc-1nln770-4 kABRub">Suggest an alternative</button></div></div></div><div class="packageName__TutorialsContainer-sc-13pfqk6-22 cbmAHA"><span class="Typography-sc-ye08y9-0 packageName__StyledPackagePageHeader-sc-13pfqk6-2 packageName__TutorialsHeader-sc-13pfqk6-23 jzJHyJ bBfEtb hionN"><a href="/js/backbone.localstorage/tutorials"><h2 class="PackagePageHeader-sc-ix6jqz-0 gRLNGO">Tutorials</h2></a></span><div class="ZeroStateOverlay__Root-sc-1nln770-0 fjUKd"><div class="ZeroStateOverlay__Body-sc-1nln770-1 xXuGK"><div style="display:inline-block;max-width:100%;overflow:hidden;position:relative;box-sizing:border-box;margin:0"><div style="box-sizing:border-box;display:block;max-width:100%"><img style="max-width:100%;display:block;margin:0;border:none;padding:0" alt="" aria-hidden="true" role="presentation" src="data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMTA4OCIgaGVpZ2h0PSIxMDA0IiB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZlcnNpb249IjEuMSIvPg=="/></div><noscript><img srcSet="/_next/image?url=%2Fpngs%2FsampleTutorials.png&amp;w=1200&amp;q=75 1x, /_next/image?url=%2Fpngs%2FsampleTutorials.png&amp;w=3840&amp;q=75 2x" src="/_next/image?url=%2Fpngs%2FsampleTutorials.png&amp;w=3840&amp;q=75" decoding="async" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" decoding="async" style="position:absolute;top:0;left:0;bottom:0;right:0;box-sizing:border-box;padding:0;border:none;margin:auto;display:block;width:0;height:0;min-width:100%;max-width:100%;min-height:100%;max-height:100%"/></div></div><div class="ZeroStateOverlay__Overlay-sc-1nln770-2 hSSRbD"><div class="ZeroStateOverlay__Label-sc-1nln770-3 jJfMsy">No tutorials found</div><a type="button" class="Pill__Root-sc-1t99j9w-0 dQDFEV ZeroStateOverlay__StyledPill-sc-1nln770-4 kABRub">Add a tutorial</a></div></div></div></div></div></div></div><footer class="Footer-sc-1dcobd0-0 SiteWideFooter__Root-sc-8vulzt-3 zZprJ fdnJqI SiteWideLayout__Footer-sc-imbkiq-3 cLUkNQ"><div class="SiteWideFooter__Container-sc-8vulzt-9 GYwvX"><div class="SiteWideFooter__InfoSocialsContainer-sc-8vulzt-8 ttGDw"><div class="SiteWideFooter__AllLinks-sc-8vulzt-4 gXTxoG"><div class="SiteWideFooter__LeftColumn-sc-8vulzt-26 kpmxFm"><div class="SiteWideFooter__ProductsRow-sc-8vulzt-19 fMuqfT"><div class="SiteWideFooter__ProductLinks-sc-8vulzt-5 dzxrQ"><div class="SiteWideFooter__Subhead-sc-8vulzt-25 hILFpg">Product</div><a href="/" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Home</a><a href="/about/openbase" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">What is Openbase?</a><a href="/categories/js" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Categories</a><a href="/random-package" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Random Package</a><a href="/leaderboard" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Leaderboard</a><a href="https://openbase.com/docs" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Documentation</a><a href="https://dev.page" rel="noopener" target="_blank" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Claim your dev.page</a><button type="button" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Contact Us</button></div><div class="SiteWideFooter__CompanyLinks-sc-8vulzt-6 MYvWk"><div class="SiteWideFooter__Subhead-sc-8vulzt-25 hILFpg">Company</div><a href="https://openbase.com/about" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">About</a><a href="https://openbase.com/careers" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Careers</a><a href="https://openbase.com/blog" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Blog</a><a href="https://openbase.com/about/media" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Media Kit</a><a href="https://openbase.com/legal/privacy" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Privacy</a><a href="https://openbase.com/legal/terms" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__InfoLink-sc-8vulzt-11 jzJHyJ iduKWb bKaXDv">Terms</a></div></div><div class="SiteWideFooter__InfoDesktop-sc-8vulzt-28 dKzXkv"><p class="SiteWideFooter__Info-sc-8vulzt-12 iKiaEN">Openbase helps developers choose among and use millions of open-source packages, so they can build amazing products faster.</p><div class="FooterSocials__Root-sc-9t8k2h-0 fDuspr SiteWideFooter__StyledSocials-sc-8vulzt-7 jjeEEn"><a target="_blank" rel="nofollow noopener" href="https://discord.com/invite/P5vFJdurmt" aria-label="Discord" class="FooterSocialButton__Root-sc-sjzr08-0 densWT"><svg xmlns="http://www.w3.org/2000/svg" width="50" height="50" viewBox="0 0 36 36"><g data-name="Discord Icon"><path fill="currentColor" data-name="Subtraction 1" d="M17.998 36.001a17.941 17.941 0 117.006-1.416 17.851 17.851 0 01-7.006 1.416zM14.833 9.962a10.788 10.788 0 00-5.094 2.041 14.5 14.5 0 00-1.359 2.818 28.738 28.738 0 00-1.7 8.391 8.863 8.863 0 004.3 2.666 9.794 9.794 0 002.312.389h.014l.831-1.117a10.093 10.093 0 01-4.4-2.959 14.335 14.335 0 0016.305.006 10.11 10.11 0 01-4.392 2.953l.831 1.117a9.733 9.733 0 002.326-.389 8.958 8.958 0 004.3-2.666 28.881 28.881 0 00-1.709-8.391 14.683 14.683 0 00-1.36-2.816 10.739 10.739 0 00-5.1-2.045l-.247.5a9.9 9.9 0 014.837 2.557 15.352 15.352 0 00-15.291 0 10.134 10.134 0 014.837-2.559zm6.361 11.211a2.056 2.056 0 111.787-2.037 1.927 1.927 0 01-1.789 2.037zm-6.629 0a2.056 2.056 0 111.787-2.037 1.926 1.926 0 01-1.787 2.037z"></path></g></svg></a><a target="_blank" rel="nofollow noopener" href="https://www.twitter.com/openbase/" aria-label="Twitter" class="FooterSocialButton__Root-sc-sjzr08-0 densWT"><svg xmlns="http://www.w3.org/2000/svg" width="50" height="50" viewBox="0 0 50 50"><path fill="currentColor" d="M25 0a25 25 0 1025 25A25 25 0 0025 0zm11.415 19.492q.017.369.016.742c0 7.582-5.772 16.326-16.327 16.327a16.242 16.242 0 01-8.8-2.578 11.671 11.671 0 001.369.079 11.514 11.514 0 007.127-2.456 5.745 5.745 0 01-5.361-3.986 5.719 5.719 0 002.592-.1 5.74 5.74 0 01-4.6-5.625v-.073a5.7 5.7 0 002.6.718 5.743 5.743 0 01-1.777-7.661 16.292 16.292 0 0011.828 6 5.741 5.741 0 019.778-5.233 11.509 11.509 0 003.644-1.393 5.761 5.761 0 01-2.523 3.174 11.444 11.444 0 003.3-.9 11.661 11.661 0 01-2.862 2.972zm0 0"></path></svg></a><a target="_blank" rel="nofollow noopener" href="https://www.linkedin.com/company/openbaseio/" aria-label="LinkedIn" class="FooterSocialButton__Root-sc-sjzr08-0 densWT"><svg xmlns="http://www.w3.org/2000/svg" width="50" height="50" viewBox="0 0 50 50"><path fill="currentColor" d="M25 0a25 25 0 1025 25A25 25 0 0025 0zm-7.265 37.793h-6.088V19.475h6.089zm-3.044-20.819h-.04a3.173 3.173 0 11.08-6.329 3.175 3.175 0 11-.04 6.329zm25 20.819H33.6v-9.8c0-2.463-.882-4.142-3.085-4.142a3.333 3.333 0 00-3.124 2.227 4.17 4.17 0 00-.2 1.486v10.229H21.1s.08-16.6 0-18.318h6.088v2.594a6.045 6.045 0 015.487-3.024c4.006 0 7.01 2.618 7.01 8.244zm0 0" data-name="linkedin icon"></path></svg></a><a target="_blank" rel="nofollow noopener" href="https://www.facebook.com/openbaseio/" aria-label="Facebook" class="FooterSocialButton__Root-sc-sjzr08-0 densWT"><svg xmlns="http://www.w3.org/2000/svg" width="50" height="50" viewBox="0 0 50 50"><path fill="currentColor" d="M25 0a25 25 0 1025 25A25.028 25.028 0 0025 0zm6.217 25.88H27.15v14.5h-6.027v-14.5h-2.865v-5.124h2.865v-3.314c0-2.374 1.128-6.082 6.082-6.082l4.466.017v4.974H28.43a1.227 1.227 0 00-1.278 1.4v3.011h4.592z" data-name="Facebook icon"></path></svg></a><a target="_blank" rel="nofollow noopener" href="https://www.github.com/openbasehq/" class="FooterSocialButton__Root-sc-sjzr08-0 densWT FooterSocials__GithubSocialButton-sc-9t8k2h-1 MVxZn" aria-label="Github"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 30 30" data-name="github icon"><path d="M14.8 0a14.8 14.8 0 00-4.679 28.849c.739.137.978-.322.978-.712v-2.755c-4.118.9-4.975-1.747-4.975-1.747a3.921 3.921 0 00-1.644-2.166c-1.343-.919.1-.9.1-.9A3.107 3.107 0 016.854 22.1a3.151 3.151 0 004.308 1.23 3.141 3.141 0 01.94-1.979c-3.287-.376-6.744-1.646-6.744-7.316a5.729 5.729 0 011.525-3.973 5.324 5.324 0 01.144-3.918s1.243-.4 4.072 1.517a14.031 14.031 0 017.412 0c2.826-1.914 4.067-1.517 4.067-1.517a5.319 5.319 0 01.146 3.918 5.714 5.714 0 011.523 3.973c0 5.686-3.463 6.938-6.759 7.3a3.538 3.538 0 011.012 2.74v4.062c0 .394.237.856.988.711A14.806 14.806 0 0014.8 0z" data-name="github icon" fill="#c6d3e7"></path></svg></a></div></div></div><div class="SiteWideFooter__MiddleColumn-sc-8vulzt-27 kgoyEp"><div class="SiteWideFooter__CategoryLinks-sc-8vulzt-13 hwokxf"><div class="SiteWideFooter__BrowseCategories-sc-8vulzt-14 hMRwmw"><div class="SiteWideFooter__BrowseCategoriesHeader-sc-8vulzt-15 hGuQyH"><svg xmlns="http://www.w3.org/2000/svg" width="15.616" height="15.616" viewBox="0 0 15.616 15.616" class="SiteWideFooter__StyledCategoriesIcon-sc-8vulzt-0 hOEVMn"><defs><style>.categories-icon_svg__cls-1{fill:#efc068}</style></defs><g id="categories-icon_svg__Categories_Icon" data-name="Categories Icon" transform="translate(-618 -181)"><rect id="categories-icon_svg__Rectangle_2158" data-name="Rectangle 2158" class="categories-icon_svg__cls-1" width="6.647" height="6.647" rx="1" transform="translate(618 181)"></rect><rect id="categories-icon_svg__Rectangle_2161" data-name="Rectangle 2161" class="categories-icon_svg__cls-1" width="6.647" height="6.647" rx="1" transform="translate(618 189.97)"></rect><rect id="categories-icon_svg__Rectangle_2159" data-name="Rectangle 2159" class="categories-icon_svg__cls-1" width="6.647" height="6.647" rx="1" transform="translate(626.97 181)"></rect><rect id="categories-icon_svg__Rectangle_2160" data-name="Rectangle 2160" class="categories-icon_svg__cls-1" width="6.647" height="6.647" rx="1" transform="translate(626.97 189.97)"></rect></g></svg>Browse Categories</div></div><div class="SiteWideFooter__CategoriesRow-sc-8vulzt-18 dwjsii"><div class="SiteWideFooter__CategoriesBody-sc-8vulzt-16 cAEOc"><div class="SiteWideFooter__CategorySubhead-sc-8vulzt-24 geWWJJ"><a href="/categories/js" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryHeader-sc-8vulzt-23 jzJHyJ iduKWb lplPqz">JavaScript</a></div><div class="SiteWideFooter__CategoriesRow-sc-8vulzt-18 dwjsii"><div class="SiteWideFooter__CategoriesColumn-sc-8vulzt-17 cgzZZE"><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js">All JavaScript Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-vanilla-javascript">Vanilla JS Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-react">React Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-vue">Vue Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-angular">Angular Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-jquery">jQuery Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-bootstrap">Bootstrap Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-material-ui">Material-UI Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-svelte">Svelte Categories</a></div><div class="SiteWideFooter__CategoriesColumn-sc-8vulzt-17 cgzZZE"><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-node">Node.js Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-express">Express.js Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-next-js">Next.js Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-gatsby">Gatsby Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright" href="/categories/js-react-native">React Native Categories</a></div></div></div><div class="SiteWideFooter__CategoriesBody-sc-8vulzt-16 cAEOc"><div class="SiteWideFooter__CategorySubhead-sc-8vulzt-24 geWWJJ"><a href="/categories/python" class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryHeader-sc-8vulzt-23 jzJHyJ iduKWb lplPqz">Python</a></div><div class="SiteWideFooter__CategoriesColumn-sc-8vulzt-17 cgzZZE"><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright libraries" href="/categories/python-python">All Python Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright libraries" href="/categories/python-vanilla-python">Vanilla Python Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright libraries" href="/categories/python-django">Django Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright libraries" href="/categories/python-flask">Flask Categories</a><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj bright libraries" href="/categories/python-asyncio">AsyncIO Categories</a></div></div></div></div><div class="SiteWideFooter__CategoryLinks-sc-8vulzt-13 hwokxf"><div class="SiteWideFooter__BrowseCategories-sc-8vulzt-14 hMRwmw"><div class="SiteWideFooter__BrowseCategoriesHeader-sc-8vulzt-15 hGuQyH"><svg xmlns="http://www.w3.org/2000/svg" width="19.617" height="19.873" viewBox="0 0 19.617 19.873" class="SiteWideFooter__StyledLibrariesIcon-sc-8vulzt-1 bucmzh"><path d="M0 9.937A9.885 9.885 0 019.808 0a9.884 9.884 0 019.809 9.937 9.883 9.883 0 01-9.809 9.937A9.884 9.884 0 010 9.937zm4.333-2.222a.626.626 0 00-.236.6l.888 5.244a.617.617 0 00.6.517h8.44a.615.615 0 00.6-.517l.889-5.244a.627.627 0 00-.235-.6.605.605 0 00-.637-.061L12.277 8.82l-1.938-3.532a.632.632 0 00-1.072 0L7.329 8.82 4.964 7.654a.621.621 0 00-.271-.063.6.6 0 00-.36.124z" fill="#bfffff"></path></svg>Browse Libraries</div></div><div class="SiteWideFooter__CategorySubhead-sc-8vulzt-24 geWWJJ"></div><div class="SiteWideFooter__CategoriesColumn-sc-8vulzt-17 cgzZZE"><div class="SiteWideFooter__LibrariesItem-sc-8vulzt-22 jnUeEf"><svg xmlns="http://www.w3.org/2000/svg" width="12.457" height="9.763" viewBox="0 0 12.457 9.763" class="SiteWideFooter__StyledCrownIcon-sc-8vulzt-2 dapzjI"><path d="M10.822 9.763H1.635a.667.667 0 01-.658-.554L.01 3.573a.667.667 0 01.95-.713l2.575 1.254 2.111-3.8a.693.693 0 011.166 0l2.111 3.8L11.5 2.862a.667.667 0 01.95.713l-.967 5.635a.669.669 0 01-.658.554z" fill="#bfffff"></path></svg><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj library" href="/categories/js/most-popular-javascript-libraries">Top JavaScript Libraries</a></div><div class="SiteWideFooter__LibrariesItem-sc-8vulzt-22 jnUeEf"><svg xmlns="http://www.w3.org/2000/svg" width="12.457" height="9.763" viewBox="0 0 12.457 9.763" class="SiteWideFooter__StyledCrownIcon-sc-8vulzt-2 dapzjI"><path d="M10.822 9.763H1.635a.667.667 0 01-.658-.554L.01 3.573a.667.667 0 01.95-.713l2.575 1.254 2.111-3.8a.693.693 0 011.166 0l2.111 3.8L11.5 2.862a.667.667 0 01.95.713l-.967 5.635a.669.669 0 01-.658.554z" fill="#bfffff"></path></svg><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj library" href="/categories/python/most-popular-python-libraries">Top Python Libraries</a></div><div class="SiteWideFooter__LibrariesItem-sc-8vulzt-22 jnUeEf"><svg xmlns="http://www.w3.org/2000/svg" width="12.457" height="9.763" viewBox="0 0 12.457 9.763" class="SiteWideFooter__StyledCrownIcon-sc-8vulzt-2 dapzjI"><path d="M10.822 9.763H1.635a.667.667 0 01-.658-.554L.01 3.573a.667.667 0 01.95-.713l2.575 1.254 2.111-3.8a.693.693 0 011.166 0l2.111 3.8L11.5 2.862a.667.667 0 01.95.713l-.967 5.635a.669.669 0 01-.658.554z" fill="#bfffff"></path></svg><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj library" href="/categories/go/most-popular-go-libraries">Top Go Libraries</a></div><div class="SiteWideFooter__LibrariesItem-sc-8vulzt-22 jnUeEf"><svg xmlns="http://www.w3.org/2000/svg" width="12.457" height="9.763" viewBox="0 0 12.457 9.763" class="SiteWideFooter__StyledCrownIcon-sc-8vulzt-2 dapzjI"><path d="M10.822 9.763H1.635a.667.667 0 01-.658-.554L.01 3.573a.667.667 0 01.95-.713l2.575 1.254 2.111-3.8a.693.693 0 011.166 0l2.111 3.8L11.5 2.862a.667.667 0 01.95.713l-.967 5.635a.669.669 0 01-.658.554z" fill="#bfffff"></path></svg><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj library" href="/categories/rust/most-popular-rust-libraries">Top Rust Libraries</a></div><div class="SiteWideFooter__LibrariesItem-sc-8vulzt-22 jnUeEf"><svg xmlns="http://www.w3.org/2000/svg" width="12.457" height="9.763" viewBox="0 0 12.457 9.763" class="SiteWideFooter__StyledCrownIcon-sc-8vulzt-2 dapzjI"><path d="M10.822 9.763H1.635a.667.667 0 01-.658-.554L.01 3.573a.667.667 0 01.95-.713l2.575 1.254 2.111-3.8a.693.693 0 011.166 0l2.111 3.8L11.5 2.862a.667.667 0 01.95.713l-.967 5.635a.669.669 0 01-.658.554z" fill="#bfffff"></path></svg><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj library" href="/categories/swift/most-popular-swift-libraries">Top Swift Libraries</a></div><div class="SiteWideFooter__LibrariesItem-sc-8vulzt-22 jnUeEf"><svg xmlns="http://www.w3.org/2000/svg" width="12.457" height="9.763" viewBox="0 0 12.457 9.763" class="SiteWideFooter__StyledCrownIcon-sc-8vulzt-2 dapzjI"><path d="M10.822 9.763H1.635a.667.667 0 01-.658-.554L.01 3.573a.667.667 0 01.95-.713l2.575 1.254 2.111-3.8a.693.693 0 011.166 0l2.111 3.8L11.5 2.862a.667.667 0 01.95.713l-.967 5.635a.669.669 0 01-.658.554z" fill="#bfffff"></path></svg><a class="Typography-sc-ye08y9-0 SiteWideFooter__NavLink-sc-8vulzt-10 SiteWideFooter__CategoryLink-sc-8vulzt-20 jzJHyJ iduKWb blRapj library" href="/categories/java/most-popular-java-libraries">Top Java Libraries</a></div></div></div></div></div><div class="SiteWideFooter__InfoMobile-sc-8vulzt-29 jDpFhK"><p class="SiteWideFooter__Info-sc-8vulzt-12 iKiaEN">Openbase helps developers choose among and use millions of open-source packages, so they can build amazing products faster.</p><div class="FooterSocials__Root-sc-9t8k2h-0 fDuspr SiteWideFooter__StyledSocials-sc-8vulzt-7 jjeEEn"><a target="_blank" rel="nofollow noopener" href="https://discord.com/invite/P5vFJdurmt" aria-label="Discord" class="FooterSocialButton__Root-sc-sjzr08-0 densWT"><svg xmlns="http://www.w3.org/2000/svg" width="50" height="50" viewBox="0 0 36 36"><g data-name="Discord Icon"><path fill="currentColor" data-name="Subtraction 1" d="M17.998 36.001a17.941 17.941 0 117.006-1.416 17.851 17.851 0 01-7.006 1.416zM14.833 9.962a10.788 10.788 0 00-5.094 2.041 14.5 14.5 0 00-1.359 2.818 28.738 28.738 0 00-1.7 8.391 8.863 8.863 0 004.3 2.666 9.794 9.794 0 002.312.389h.014l.831-1.117a10.093 10.093 0 01-4.4-2.959 14.335 14.335 0 0016.305.006 10.11 10.11 0 01-4.392 2.953l.831 1.117a9.733 9.733 0 002.326-.389 8.958 8.958 0 004.3-2.666 28.881 28.881 0 00-1.709-8.391 14.683 14.683 0 00-1.36-2.816 10.739 10.739 0 00-5.1-2.045l-.247.5a9.9 9.9 0 014.837 2.557 15.352 15.352 0 00-15.291 0 10.134 10.134 0 014.837-2.559zm6.361 11.211a2.056 2.056 0 111.787-2.037 1.927 1.927 0 01-1.789 2.037zm-6.629 0a2.056 2.056 0 111.787-2.037 1.926 1.926 0 01-1.787 2.037z"></path></g></svg></a><a target="_blank" rel="nofollow noopener" href="https://www.twitter.com/openbase/" aria-label="Twitter" class="FooterSocialButton__Root-sc-sjzr08-0 densWT"><svg xmlns="http://www.w3.org/2000/svg" width="50" height="50" viewBox="0 0 50 50"><path fill="currentColor" d="M25 0a25 25 0 1025 25A25 25 0 0025 0zm11.415 19.492q.017.369.016.742c0 7.582-5.772 16.326-16.327 16.327a16.242 16.242 0 01-8.8-2.578 11.671 11.671 0 001.369.079 11.514 11.514 0 007.127-2.456 5.745 5.745 0 01-5.361-3.986 5.719 5.719 0 002.592-.1 5.74 5.74 0 01-4.6-5.625v-.073a5.7 5.7 0 002.6.718 5.743 5.743 0 01-1.777-7.661 16.292 16.292 0 0011.828 6 5.741 5.741 0 019.778-5.233 11.509 11.509 0 003.644-1.393 5.761 5.761 0 01-2.523 3.174 11.444 11.444 0 003.3-.9 11.661 11.661 0 01-2.862 2.972zm0 0"></path></svg></a><a target="_blank" rel="nofollow noopener" href="https://www.linkedin.com/company/openbaseio/" aria-label="LinkedIn" class="FooterSocialButton__Root-sc-sjzr08-0 densWT"><svg xmlns="http://www.w3.org/2000/svg" width="50" height="50" viewBox="0 0 50 50"><path fill="currentColor" d="M25 0a25 25 0 1025 25A25 25 0 0025 0zm-7.265 37.793h-6.088V19.475h6.089zm-3.044-20.819h-.04a3.173 3.173 0 11.08-6.329 3.175 3.175 0 11-.04 6.329zm25 20.819H33.6v-9.8c0-2.463-.882-4.142-3.085-4.142a3.333 3.333 0 00-3.124 2.227 4.17 4.17 0 00-.2 1.486v10.229H21.1s.08-16.6 0-18.318h6.088v2.594a6.045 6.045 0 015.487-3.024c4.006 0 7.01 2.618 7.01 8.244zm0 0" data-name="linkedin icon"></path></svg></a><a target="_blank" rel="nofollow noopener" href="https://www.facebook.com/openbaseio/" aria-label="Facebook" class="FooterSocialButton__Root-sc-sjzr08-0 densWT"><svg xmlns="http://www.w3.org/2000/svg" width="50" height="50" viewBox="0 0 50 50"><path fill="currentColor" d="M25 0a25 25 0 1025 25A25.028 25.028 0 0025 0zm6.217 25.88H27.15v14.5h-6.027v-14.5h-2.865v-5.124h2.865v-3.314c0-2.374 1.128-6.082 6.082-6.082l4.466.017v4.974H28.43a1.227 1.227 0 00-1.278 1.4v3.011h4.592z" data-name="Facebook icon"></path></svg></a><a target="_blank" rel="nofollow noopener" href="https://www.github.com/openbasehq/" class="FooterSocialButton__Root-sc-sjzr08-0 densWT FooterSocials__GithubSocialButton-sc-9t8k2h-1 MVxZn" aria-label="Github"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 30 30" data-name="github icon"><path d="M14.8 0a14.8 14.8 0 00-4.679 28.849c.739.137.978-.322.978-.712v-2.755c-4.118.9-4.975-1.747-4.975-1.747a3.921 3.921 0 00-1.644-2.166c-1.343-.919.1-.9.1-.9A3.107 3.107 0 016.854 22.1a3.151 3.151 0 004.308 1.23 3.141 3.141 0 01.94-1.979c-3.287-.376-6.744-1.646-6.744-7.316a5.729 5.729 0 011.525-3.973 5.324 5.324 0 01.144-3.918s1.243-.4 4.072 1.517a14.031 14.031 0 017.412 0c2.826-1.914 4.067-1.517 4.067-1.517a5.319 5.319 0 01.146 3.918 5.714 5.714 0 011.523 3.973c0 5.686-3.463 6.938-6.759 7.3a3.538 3.538 0 011.012 2.74v4.062c0 .394.237.856.988.711A14.806 14.806 0 0014.8 0z" data-name="github icon" fill="#c6d3e7"></path></svg></a></div></div></div></div><div class="SiteWideFooter__Copyright-sc-8vulzt-21 iuNeSd">© <!-- -->2022<!-- --> Openbase, Inc.</div></footer></div></div><script id="__NEXT_DATA__" type="application/json">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</script></body></html>