bpd

babel-plugin-dynamic-import-node-babel-7

Babel plugin to transpile import() to a deferred require(), for node

Showing:

Popularity

Downloads/wk

9K

GitHub Stars

6

Maintenance

Last Commit

2yrs ago

Contributors

11

Package

Dependencies

1

Size (min+gzip)

1.2KB

License

MIT

Type Definitions

Tree-Shakeable

No?

Categories

Readme

babel-plugin-dynamic-import-node

NOTE: THE ORIGINAL NOW SUPPORTS BABEL 7

As of March 2019, airbnb/babel-plugin-dynamic-import-node supports Babel 7 out-of-the-box, so you probably don't need to use this.

FORK OF THE ORIGINAL TO TEST WITH BABEL 7

If you're looking for the original one, check on: Github This fork was created to add support for Babel 7: Github

Babel plugin to transpile import() to a deferred require(), for node. Matches the proposed spec.

NOTE: Babylon >= v6.12.0 is required to correct parse dynamic imports.

Installation

$ npm install babel-plugin-dynamic-import-node-babel-7 --save-dev

Usage

.babelrc

{
  "plugins": ["dynamic-import-node-babel-7"]
}

Via CLI

$ babel --plugins dynamic-import-node script.js

Via Node API

require('babel-core').transform('code', {
  plugins: ['dynamic-import-node']
});

Code Example

Promise.all([
  import('./lib/import1'),
  import('./lib/import2')
 ]).then(([
   Import1,
   Import2
  ]) => {
   console.log(Import1);
   /* CODE HERE*/
  });

Rate & Review

Great Documentation0
Easy to Use0
Performant0
Highly Customizable0
Bleeding Edge0
Responsive Maintainers0
Poor Documentation0
Hard to Use0
Slow0
Buggy0
Abandoned0
Unwelcoming Community0
100